Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fresh installation of Ubuntu 12.04, I have been running it for about a week. Suddenly today I noticed my computer freezes every 5 seconds. I restarted the computer and I still get this. I believe it is a process called watchdog/0 that is using all the resources. See the attached pictures.

How can I stop this? I can barely use my computer like this.

see CPU hits 100% when idle it is the watchdog process

UPDATE

Well I just did a cold reboot, (shutdown, unplug, and plug back in, and turn on) and it seems to have fixed it. After looking at the man page for watchdog, it seems that this process may stay on during a restart? so it is more like a soft restart? Why that happens I don't know.

share|improve this question

4 Answers 4

Here's a quick summary of what it does:

The watchdog program writes to /dev/watchdog every ten seconds. If the device is opened but not written to within a minute, the machine will reboot. This feature is available when the kernel is built with ‘software watchdog’ support (standard in Debian kernels).

While it may seem useful, it's not really that crucial for your system's reliability, moreover it tends to cause unnecessary wakeups which in turn may lead to shorter battery performance/ You can easily disable it by adding nmi_watchdog=0 to your kernel boot parameters in /etc/defaults/grub.

share|improve this answer
    
Thanks that sounds like a good solution. I wonder why it was eating all the CPU usage every few seconds? –  jeffery_the_wind May 10 '12 at 10:44
    
Did not work for me, unfortunately. Watchdog is still there, after adding the line to /etc/defaults/grub. –  twigmac Mar 18 at 15:29

This could be related to https://bugs.launchpad.net/ubuntu/+source/watchdog/+bug/1010855 or https://bugzilla.kernel.org/show_bug.cgi?id=42981

On my system, rebooting works around the issue, but it comes back after a few hours.

share|improve this answer
    
Further news on this issue: when I upgraded the kernel on the system in question (a Dell R720 with 16 cores) to 3.8.0-31.46~precise1 (tip: use package linux-image-generic-lts-raring), the problem went away. –  Paul Gear Oct 18 '13 at 11:07
    
Actually, it looks like linux-image-current-generic might be a better long-term choice, since it doesn't depend on the name of the current release. –  Paul Gear Jan 22 at 2:45

My server is a Dell R320, 12 cores, watchdog drain CPU heavily, avg. 68% CPU usage.

Add following drivers to blacklist configuration file /etc/modprobe.d/blacklist.conf fixed my problem

blacklist acpi_pad
blacklist mei
blacklist sb_edac
blacklist i7core_edac
share|improve this answer

I was able to tranquilise the watchdog by stepping down with the kernel version. Therefore I had to make the grub menu visible as described in this Q&A.

After choosing an earlier kernel during startup, the watchdog was calm. However, then rtkit-deamon went totally crazy eating the same amount of the CPU as the watchdog did before.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.