Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Xubuntu 12.04 with latest updates on Toshiba Satellite A210-15K laptop

semen@bloknot:~$ uname -a
Linux bloknot 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

...and I can't adjust LCD brightness (. I tried to use fnfx tool:

semen@bloknot:~$ fnfx-client
FnFX Client v0.3 (c) 2003, 2004 Timo Hoenig <thoenig@nouse.net>

fatal error: Could not open "/home/semen/.fnfxrc". Please make sure that the default config is accessible.

...and xbacklight:

semen@bloknot:~$ xbacklight
No outputs have backlight property

...and I tried to add acpi_osi=Linux and acpi_backlight=vendor parameters in GRUB config, but nothing happens.

I soppose .fnfxrc file must be available after installation or first fnfx demon lauch. Isn't it?

semen@bloknot:~$ cat /sys/class/backlight/toshiba/brightness
-5
semen@bloknot:~$ cat /sys/class/backlight/toshiba/max_brightness
7
semen@bloknot:~$ echo 6 | sudo tee /sys/class/backlight/toshiba/brightness
[sudo] password for semen: 
6
...

...but brightness is the same.

Help, please.

P.S. Execuse me for my poor English.

UPD. I have spent 2 days to solve this boring problem, but I can't. So. If I wish linux work correctly, I have to choose another distro.

share|improve this question
    
Try this first, so we know it's possible to even adjust the brightness. –  Chan-Ho Suh May 10 '12 at 8:19
    
I tried it, but brightness is still at the same level –  Semen May 10 '12 at 8:33
    
That's not too good, but there's another good possibility. Do you use the default radeon driver? Or did you install the proprietary driver? You can check by typing lspci -v in the terminal and looking for the section heading with VGA in it. Kernel driver in use will state radeon if you are using the default. –  Chan-Ho Suh May 10 '12 at 8:41
    
Yes. This laptop is not "fresh" ) and there is default radeon driver only. –  Semen May 10 '12 at 8:44
    
You can try installing fglrx proprietary driver, which supports your graphics card, and see if brightness will work then. I believe you can just sudo apt-get install fglrx. Many people use it and have no problems... but switching graphics drivers can cause major issues. Please don't do this unless you really are bugged by the brightness issue. –  Chan-Ho Suh May 10 '12 at 8:56
show 2 more comments

3 Answers

I have a Toshiba Satelite A100 and for me the following command works:

echo 0 | sudo tee  /sys/class/backlight/acpi_video0/brightness
share|improve this answer
add comment

Your graphics driver is part of the default installation. To check it and to know which driver is currently in use open a terminal and type this in:

sudo lshw -C display

Look for a line that says configuration: driver=i915 latency=0. If its present then the drivers are enabled. To keep the driver updated you just need to keep your system updated with the Update Manager. To be able to use the brightness buttons you need to add something to your grub configuration file.

Open it with you favorite text editor in a terminal, ie gedit

gksudo gedit /etc/default/grub

Locate the line

GRUB_CMDLINE_LINUX=""

and change it to

GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi_backlight=vendor"

Save the file and in a terminal type

sudo update-grub

Reboot your computer. Your brightness buttons should now be working as expected.

Source: Unable to adjust screen brightness on Gateway NV54

share|improve this answer
add comment
function brightness() {
    echo $(echo `cat /sys/class/backlight/acpi_video0/brightness`$1$2|bc)|sudo tee /sys/class/backlight/acpi_video0/brightness
}

Save that to your ~/.bashrc.

Then type brightness +10 to increase or brightness -10 to decrease. It requires password for sudo though.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.