Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.04 LTS on my dell inspiron 1464. Everything is working fine. Except my LED brightness.

Every time I adjust it to my suitable level. But after reboot it goes on high as it was before. This is quite irritating specially at night.

I do not face this problem in previous version. How can I lock my brightness to my preference?

share|improve this question
    
Have a read of this ubuntuforums.org/showthread.php?p=11910629#post11910629 –  Srinivas Gowda May 10 '12 at 6:31
    
And this askubuntu.com/questions/128285/… –  Srinivas Gowda May 10 '12 at 6:33
add comment

1 Answer

up vote 4 down vote accepted

I faced the same problem on my Dell XPS. Currently there is no other way to save it according to brightness key.

  • First try executing

    sudo su -c 'echo 5 > /sys/class/backlight/acpi_video0/brightness'
    

If it succed,try with different value for 5 and choose your preference level.

  • Now edit /etc/rc.local file to execute this command at boot up.

    gksu gedit /etc/rc.local
    
  • Just before exit in the file, add the following line,

    echo 5 > /sys/class/backlight/acpi_video0/brightness
    

You can change value 5 to anything.

share|improve this answer
2  
You can use a shutdown script to save the last brightness setting from that file and then echo the saved value as above on startup. Also, instead of the directory acpi_video0 you might have a different one. You can find the right path by using ls /sys/class/backlight/*/brightness. –  Chan-Ho Suh May 10 '12 at 7:20
    
will try this definitely –  Web-E May 10 '12 at 9:13
    
Also, sudoedit is a better option compared to gksu gedit since sudoedit automatically fires up the user's default text editor. Kindly update your answer with this, and generaise it based on instructions given by ChanHoSuh. –  Mahesh May 10 '12 at 11:25
    
my problem is solved. thanks to Web-E –  Sazzad May 10 '12 at 14:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.