Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Nvidia GeForce 7300 SE. It worked fine with the nvidia driver when I was using 10.10. When I upgraded to 12.04, the (nvidia-current) binary driver failed---I couldn't even get a login screen. The "nouveau" driver works okay, but the display is quite sluggish.

I've read about the fact that my GeForce is blacklisted (here and here). But, when I tried the suggested workaround of using nvidia-173, I discovered that it wouldn't install because of a failed dependency: xorg-video-abi-10 (Package not available). The "precise" nvidia-173 package page notes this (dependency bug?)

So, my real question: is there a GeForce 7300 SE workaround for 12.04?

share|improve this question
1  
jrennie, this is a known bug (regression) with the 295.40 driver that ships with 12.04. nVidia has released 295.49 that fixes this, but as far as I can tell, this hasn't been pushed to the ubuntu repos yet. It may appear in the ppa:ubuntu-x-swat/x-updates ppa soon or hopefully the nvidia-current-updates package. Until then you could download and install the driver manually, or suffer with nouveau. –  Chris May 10 '12 at 3:06
    
Looks like my problem may be different---295.49 still gives me a segfault; I added a comment to the bug. –  jrennie May 11 '12 at 2:05
    
That is too bad. nVidia lists your card as supported by the 295.49 driver. It worked for me, though I am not using the same card. I suppose you could try the 302.07 beta driver. Otherwise, I got nada. –  Chris May 11 '12 at 21:18

1 Answer 1

In my case, Im using Linux Mint, but i guess that all repositories in this os is still the same as in Ubuntu, Using Linux Mint Maya (Ubuntu 12.04 equivalent in precise) I followed this forum

http://forums.linuxmint.com/viewtopic.php?f=42&t=102602

Since Nvidia-96 is not available on any higher versions (precise and upper i guess), in this forum, they tried to get the Nvidia package to a lower ubuntu version (oneiric) and use it to their current OS and downgrade their xorg to oneiric.

Now these steps are still working in my system, and I'm using oneiric nvidia-96. Nvidia-173 is also available to oneiric repository. But please read all the recommendations in the link above to avoid problems.

share|improve this answer
3  
Welcome to askubuntu! While this may theoretically answer the question, and its very helpful that you included information on your own experience, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  John S Gruber Jun 9 '12 at 17:30
    
Does your computer use the GeForce 7300SE card, or another Nvidia card? –  hexafraction Aug 2 '12 at 12:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.