Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What is the easiest way to enable PHP on nginx on Ubuntu 12.04?

Best solution is the one that request minimal work, ideally just a package installation :)

share|improve this question

2 Answers 2

up vote 60 down vote accepted

The following method will get you started fast on Ubuntu 12.04:

Install the dependences:

sudo apt-get install php5-common php5-cli php5-fpm

Install nginx:

sudo apt-get install nginx

Start nginx:

sudo service nginx start

Test that it's working (should see "Welcome to nginx!")

sudo service nginx stop

In your nginx site configuration (/etc/nginx/sites-available/default), uncomment the lines in the server {} section starting with

listen for ipv4 / ipv6 both.

scroll down to where it says "location ~ .php {" and uncomment lines so it looks like this:

location ~ \.php$ {
  fastcgi_split_path_info ^(.+\.php)(/.+)$;
  fastcgi_pass 127.0.0.1:9000;
  fastcgi_index index.php;
  include fastcgi_params;
}

sudo service php5-fpm restart sudo service nginx restart

Your default web root is located at /usr/share/nginx/www (per the config file). (See root /usr/share/nginx/www;

(Note: For Ubuntu 12.10 or newer, you will need to replace the fastcgi_pass 127.0.0.1:9000; line with this to make it work: fastcgi_pass unix:/var/run/php5-fpm.sock;)

share|improve this answer
8  
There's a problem here. For 12.10 and newer, you will need to use fastcgi_pass unix:/var/run/php5-fpm.sock instead of the 127.0.0.1:9000 that is in your example. I added that information to the end of the answer. –  Thomas W. Mar 7 '13 at 5:22
    
As a late side note, you can make 12.04 use a UNIX socket like 12.10+ does by editing /etc/php5/fpm/pool.d/www.conf and changing the listen line to listen = /var/run/php5-fpm.sock, then using the line @ThomasW. mentioned. –  Powerlord Mar 30 at 19:53
    
@Powerlord the NGINX default setup has both lines and explains the difference between the two, rather than having to change how PHP runs you can just change the config line in NGINX faster, and all works. –  Thomas W. Mar 30 at 23:36
    
@ThomasW. The NGINX defaults setup's description of both lines is also wrong in 12.04. php5-fpm requires the first method due to how php5-fpm is configured in 12.04. It didn't change to the second method until 12.10. To make php5-fpm work with nginx as documented, you have to modify fpm's www.conf as mentioned in my previous message. –  Powerlord Mar 31 at 0:53
2  
there is a missing ; at the fastcgi_split_path_info line end –  Kristóf Dombi May 10 at 8:14

The answer of @papashou is correct.

As I use Ubuntu 12.10, the configuration is a bit different. Here is what I did:

Install

sudo apt-get install nginx php5-fpm

Enable PHP

Uncomment the following lines in configuration file /etc/nginx/sites-available/default

location ~ \.php$ {
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini

#   # With php5-cgi alone:
#   fastcgi_pass 127.0.0.1:9000;
    # With php5-fpm:
    fastcgi_pass unix:/var/run/php5-fpm.sock;
    fastcgi_index index.php;
    include fastcgi_params;
}

Start (or restart)

sudo service php5-fpm restart
sudo service nginx restart

Test nginx

Opening this link http://localhost should display "Welcome to nginx!"

Test php

Create a php file:

> grep -w '^[^#]*root' /etc/nginx/sites-available/default
    root /usr/share/nginx/www;
> cd /usr/share/nginx/www
> sudo su
# echo '<?php phpinfo(); ?>' > info.php

Opening http://localhost/info.php should display the PHP information page.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.