Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I got an brand new Dell XPS 13 and I really like it. Wifi/Bluetooth/Brightness works very well. But only the Touchpad makes me insane. Okay, Multitouch is really nice and i love it on my Macbook but... i must click to click. How can I set up that is an "touch" to click?

Its makes me insane.

click, click, click.. Can I configure it?

Update: I checked the proc/devices and got:

I: Bus=0011 Vendor=0002 Product=0005 Version=0000
N: Name="ImPS/2 Generic Wheel Mouse"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input11
U: Uniq=
H: Handlers=mouse0 event11 
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0
B: REL=103

Its really bad - and anyone have an Idea that Ubuntu thinks that is an Touchpad??

share|improve this question

5 Answers 5

up vote 1 down vote accepted

Add this PPA to your system:

https://launchpad.net/~kamalmostafa/+archive/dellxps

The changes will hopefully eventually make it into the Ubuntu archive's kernel, but for now that will enable things.

share|improve this answer
    
This is now outdated. All changes should be in 13.04. The blogpost below - ken-mcconnell.com/2012/07/22/… gives a link to a usefull tool. –  anders.norgaard May 22 '13 at 13:43

it looks like ubuntu is still fixing this https://bugs.launchpad.net/ubuntu/+source/linux/+bug/978807

share|improve this answer
    
Hope that he fix it fast –  Dennis Wisnia May 11 '12 at 17:15

http://ken-mcconnell.com/2012/07/22/trackpad-sensitivity-in-ubuntu-on-dell-xps-13/

this is an additional tool for tweaking your touchpad

share|improve this answer
2  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Aditya May 7 '13 at 9:45

Open up 'System Settings' -> 'Mouse and Touchpad' -> click the 'Touchpad' tab and check 'Enable mouse clicks with touchpad'

Alternatively, if you would like even more control over your touchpad, open up the 'Ubuntu Software Center' and search for and install 'Synaptiks'

share|improve this answer
    
I saw only an "Mouse" Tab. No "Touchpad" –  Dennis Wisnia May 9 '12 at 20:59
1  
Appears to be a bug, the touchpad is closed source and linux drivers have not been created yet, it appears Dell recognizes this and is working to fix it - bartongeorge.net/2012/05/07/… –  LinuxPS2 May 9 '12 at 23:03
    
Seems that I should wait for the driver... –  Dennis Wisnia May 10 '12 at 8:24

I had the same problem on my XPS. A good solution is :

> sudo -i
> touch /etc/modprobe.d/blacklist_i2c_hid.conf
> gedit /etc/modprobe.d/blacklist_i2c_hid.conf
> write : blacklist i2c_hid
> restart

Finally, you could have the multitouch : 'System Settings' -> 'Mouse and Touchpad'

share|improve this answer
    
I found this here : ubuntuforums.org/showthread.php?t=2200363 –  darunia Mar 27 at 18:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.