Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Mozilla Firefox 12 is very slow on Ubuntu 12.04 LTS. I'm saying this because I'm using it side by side with PC. I doubt that hardware acceleration was enabled with Firefox on Ubuntu, even with css animation, it lags just like my grand dad. So, how can I check it?

I have enabled the option in advance tab. I have installed my GPU driver, however my ATI Radeon HD5650 GPU on my laptop is VESA: MADISON in system detail, is this all right?

I still can't change to Chromium because it is very buggy unlike Chrome, and with its boring add-on/extension, I don't think I would want to change soon. Opera is a good deal but it can't render my language correctly. So, Firefox is my only choice, even on PC, and it's the fastest browser on PC, and the slowest browser on Ubuntu. Please help me fix this, thanks.

share|improve this question
    
Type about:support in the address bar, hit Enter and scroll down to the graphics section. What do you see? Unfortunately, hardware acceleration is not available for all hardware, especially if you use a custom built, you personal and very own, graphics driver. I'd suggest trying the AMD driver provided by Ubuntu. –  mikewhatever May 9 '12 at 18:14
    
@mikewhatever I have installed the driver that is in setting > additional drivers. I think it's the AMD driver provided by Ubuntu. And in there it says activated. I even have AMD Catalyst Control Center with me and it's usable. But in system detail, it says my graphic is VESA: MADISON. I don't know why. –  Kreaninw D. Unlimited May 9 '12 at 18:25
    
You can try to deactivate the driver (then reboot) to see if that makes a difference. You can do that from Dash (tap Alt) then type "drivers". EDIT: No, don't tap alt. Click the ubu logo at top left. –  gecko May 9 '12 at 19:23
    
Possible duplicate of Why is Firefox too slow? –  Basharat Sialvi May 9 '12 at 21:40
    
@gecko Your name sound like you're Mozilla dev. >.< I have deactivated my driver. But nothing changed. –  Kreaninw D. Unlimited May 10 '12 at 6:53

3 Answers 3

The problem is most likely with your graphics driver.

Attempt to install the ATI binary driver: https://help.ubuntu.com/community/BinaryDriverHowto/ATI

share|improve this answer
    
This is my $ fglrxinfo. OpenGL vendor string: Advanced Micro Devices, Inc. OpenGL renderer string: ATI Mobility Radeon HD 5000 Series OpenGL version string: 4.2.11627 Compatibility Profile Context According to how to link, my driver looks fine. –  Kreaninw D. Unlimited May 9 '12 at 18:31
    
Yeah true. Did you try with the open source driver? That's before you installed ATI driver via "Additional Drivers". –  lightrush May 9 '12 at 18:38
    
Nope. When I first install Ubuntu, Unity lags pretty well. That is why I search for the driver. I think, i don't want to go back. –  Kreaninw D. Unlimited May 9 '12 at 18:54

Did you copy/paste your old profile ?

I did and it was unbearably slow. I started with a fresh profile and it was fast again. Even after installing everything back again.

You can compare by creating another profile firefox -P -no-remote. Using a second profile help re-installing everything back too..

share|improve this answer
    
This is my fresh install Ubuntu and Firefox. –  Kreaninw D. Unlimited May 9 '12 at 19:08

Slow on rendering the web pages or on connecting to the web sites ?

If the latter, try to disable the multicast dns in /etc/nsswitch.conf

share|improve this answer
    
It's very slow on rendering the web pages. Not on internet connection. –  Kreaninw D. Unlimited May 9 '12 at 19:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.