Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this problem:

desktop with empty frame

Larger image

Seems like something has frozen. This happens after every reboot now. How do I track what is frozen and what to kill?

share|improve this question
1  
I think it is KDE desktop widget. No need to kill that. –  Extender Nov 16 '10 at 6:28
1  
But how to remove this annoying frame? –  Daniel Excinsky Nov 16 '10 at 6:40
    
by removing the widget. –  RolandiXor Apr 8 '11 at 17:37
add comment

3 Answers 3

You could try using xkill and clicking on the empty spot to see if it goes away. If it does, perhaps look at a system monitor and see which process got killed.

share|improve this answer
add comment

I had exactly the same problem. It's not ideal but I found getting rid of the bottom task bar seemed to let me get rid of the 'ghost' of the frozen plasma widget too.

If you want to restore the KDE desktop to default, deleting the .kde directory in your home directory will do it. Then just log back in (back up your .kde dir just in case, though!).

Bear in mind that you'll lose other KDE specific settings, too (like your keyring settings, and so on). There IS a specific file in the .kde dir you can delete to reset plasma/desktop-specific stuff, but when I tried it it only seemed to work by removing the whole directory - which is why I recommend backing it up first.

share|improve this answer
add comment

The simple answer is to toggle the desktop effects on and off once. Press the key combination SHIFT+ALT+F12 once, which will toggle desktop effects off. Your desktop will look a bit ugly, but just wait a few seconds and then press the same keys again, which will turn it back on. Your little artifact should be gone now. As to why it happens I'm not sure, but this fixes the issue after login. You'll probably have to repeat it every other login or so.

As a "bonus", If this happens a lot, you may want to put the "Toggle desktop compositing" widget on your taskbar. Click the little cashew icon to the far right on your taskbar, then click "Add widgets" in the little window that appears. In the top left of that window is a little search/filter input box. Type "toggle" (without the quotes) and select the "Toggle desktop effects" widget by doublie-clicking on it. You should now have a little button on your panel that you can click instead of having to click SHIFT+ALT+F12.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.