Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.04 on my wifes Dell Inspiron 1501, which uses an R300 ATI graphics chip. Neither the Dash or HUD appear when pushing the appropriate key. When I try unity --reset & in the terminal, I see that over and over it's spitting out:

r300: CS space validation failed. (not enough memory?) Skipping rendering.

This is just after starting Ubuntu with no apps open, so I find it hard to believe that just rendering the Dash / HUD is completely blowing out the VRAM. Any suggestions on getting this working?


/usr/lib/nux/unity_support_test -p 

shows

OpenGL vendor string: X.Org R300 
Project OpenGL renderer string: Gallium 0.4 on ATI RS480 
OpenGL version string: 2.1 Mesa 8.0.2 
Not software rendered: yes
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: yes

All sections say "YES"

share|improve this question
    
Seems to be the same error as: askubuntu.com/questions/95675/… and: askubuntu.com/questions/79874/… –  Ubuntiac May 9 '12 at 16:11
    
/usr/lib/nux/unity_support_test -p OpenGL vendor string: X.Org R300 Project OpenGL renderer string: Gallium 0.4 on ATI RS480 OpenGL version string: 2.1 Mesa 8.0.2 All sections say "YES" –  Ubuntiac May 9 '12 at 16:12
1  
I would suggest filing a bug report on launchpad/bugzilla (include if possible xorg.log, dmesg, glxinfo, lscpi and .xsession-errors) –  Rinzwind May 9 '12 at 17:32
add comment

closed as off topic by Jorge Castro, Ringtail, maythux, Mitch, Stephen Myall Oct 16 '12 at 10:21

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers

The Unity 2d desktop might fix this issue,

You can Access Unity 2D at the LighDM log in screen (only if you have automatic login disabled).

share|improve this answer
add comment

I had the same problem, tried countless things, and using Unity 2D it indeed fixed the problem.

This was on a Dell Dimension e510. Clicking on the Dash icon did not display the Dash window, but if I typed (invisibly) 'terminal' and pressed Enter, a terminal opened.

unity --reset is suggested elsewhere, and this produces endless r300 errors as the initial post described. With Unity 2D, it works fine.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.