Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just upgraded to Kubuntu 12.04 and having problems installing Gimp 2.8, I was wondering if anyone can help me?

I've followed these instructions:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp

but get this error:

The following packages have unmet dependencies.
gimp : Depends: libwebkitgtk-1.0-0 (>= 1.3.10) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I've tried running these and trying again with the same problems:

sudo apt-get clean 
sudo apt-get autoremove 
sudo apt-get update 
sudo apt-get upgrade 
sudo apt-get -f install

also running

sudo apt-get install  libwebkitgtk-1.0-0

gives me this error

The following packages have unmet dependencies.
 libwebkitgtk-1.0-0 : Depends: libgail18 (>= 1.18.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

and then running

sudo apt-get install  libgail18

gives me this error

The following packages have unmet dependencies.
 libgail18 : Depends: libgtk2.0-0 (= 2.24.10-0ubuntu6) but 2.24.10-1oneiric6~ppa is to be installed
E: Unable to correct problems, you have held broken packages.

The bit that caught my attention was but 2.24.10-1oneiric6~ppa is to be installed - but I don't know what to do with this. I've rebooted and the error messages are the same. Can anyone help?

** EDIT ** I've found someone with the same problem, unfortunately the link is in German so I can't completely understand what the solution (last post) is - here's the google translated link : http://translate.google.com/translate?sl=auto&tl=en&js=n&prev=_t&hl=en&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Fwebcache.googleusercontent.com%2Fsearch%3Fq%3Dcache%3A1U2Uat6XqUsJ%3Aforum.ubuntuusers.de%2Ftopic%2Fprobleme-nach-update-fehlerhafte-pakete-aus-on%2F%2B%26cd%3D3%26hl%3Den%26ct%3Dclnk%26gl%3Duk&act=url

share|improve this question

2 Answers 2

Firstly remove the gimp 2.8 repo by running these commands

sudo apt-get install ppa-purge

sudo ppa-purge ppa:otto-kesselgulasch/gimp


And then run

sudo apt-get update


now remove the plugin-registery as it is not supported on 2.8

sudo apt-get remove gimp-plugin-registry


Once thats done you can install Gimp 2.8

sudo add-apt-repository ppa:otto-kesselgulasch/gimp

sudo apt-get update

sudo apt-get install gimp


After Gimp 2.8 is installed successfully, here's how you can install plugin-registry on gimp 2.8.

http://www.webupd8.org/2012/05/install-gimp-plugin-registry-for-gimp.html

share|improve this answer
    
Thanks for your reply - having done all of the above I've still got the same issue. Full output here : pastebin.com/PCMN0Min –  Martyn May 9 '12 at 16:26
    
No prob, here's what you need to do. Install synaptic package manager and search for Gimp related files. Remove all Gimp relating files. Also check if you can run the repair for broken packages in synaptic. –  Srinivas Gowda May 9 '12 at 16:39
    
I've done this and have removed everything I can see which is explicitly gimp related but still getting the same error message. Here're the left over installed items when searching for gimp - tinypic.com/view.php?pic=2qxrp0o&s=6 –  Martyn May 10 '12 at 8:55

I found a solution!
I also had this problem, must have tried every command of apt-get, purging the repository, manually deleting all other source lists under /etc/apt/, updating, etc - but still the package manger was saying that it wanted to install the '2.24.10-1oneiric6~ppa' version even though I knew that there was no trace (that I knew of) of any ppa for apt-get. I tried playing around with aptitude and that downgraded libgtk2.0-0 for me and everything started installing correctly. I don't remember exactly what I used since I really only use aptitude to search for packages in my konsole but searching for libgtk2 then marking it for upgrade did the trick. Incomplete directions below and ignore the quotes:

sudo apt-get install aptitude
sudo aptitude

press "/" to start searching
type in the name of the offending package
you may have to press "/" then enter again, do until you find it
press "+" to upgrade or "i" to install
This is when aptitude offered to downgrade
press "g" to do the upgrade/installation

You and also use the mouse to click on the words to do the same.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.