Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I do that?

I have followed this https://help.ubuntu.com/community/HybridGraphics but it didn't work

I'm getting the error at boot that the /sys/kernel/debug/vgaswitcheroo/switch don't exist , so the problem seems to be that the /sys/kernel/debug don't exist when the grub parameters are processed and it is created after the grub parameter processing.

So far I have made an alternative method, which works. In rc.local I granted full access to my user to /sys/kernel/debug then also to /sys/kernel/debug/vgaswitcheroo/switch and then I have made a simple script to switch the graphics to intel and putted it in ~./confif/autostart. The script is executed every time I log in to gnome. It's working however it would be nice if it worked at boot, as is described at that help.ubuntu.com page.

Any ideas?

Thanks

share|improve this question
    
If you have a nvidia card, you might be interested in bbswitch. You can install it from the bumblebee/stable PPA or from source, github.com/Bumblebee-Project/bbswitch. For Optimus laptops, see also askubuntu.com/q/36930/6969 –  Lekensteyn May 10 '12 at 19:39

1 Answer 1

The commands in rc.local are executed every time your computer boots.

So you just need to add the commands that power down the discrete adapter right before you chown the vgaswitcheroo/switch file

I turn off my radeon adapter every time I boot as well. My rc.local is very simple:

# [...]
# By default this script does nothing.

# turn off the discrete video adapter
echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

exit 0

I don't bother with any other scripts, but if you do they should still work just fine. Just put the echo OFF before the chown or any of the other user scripts.

Ubuntu has hibernation turned off by default, but note that if you do turn it on this method doesn't get a chance to run when you come out of hibernation (not sleep) so both adapters will be powered up.

share|improve this answer
    
Even when you suspend your laptop both adapter will be powered when it woke up. I know that rc.local is executed every boot and first I tried to do it your way however the x server won't start then, don't know why, but if I have it in separated file and executing that (switch) file in session autostart it all works how it should(except both card are powered up until login) –  Jan May 15 '12 at 19:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.