Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a Dell XPSL502 15' and it's facing hybrid graphics problem. I'm really desperate, I don't know what to do - how should I fix this?

This problem has occurred before on other Linux variatns for me too, e.g. Blackbuntu, Bachtrack, Debian 6.0.4 Squeeze, Chackra, ...

Please help me if you solved this problem.

share|improve this question

marked as duplicate by AgentCool, user68186, bcbc, Eric Carvalho, Kevin Bowen May 22 '13 at 9:05

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

I am having the same laptop and running 12.04 flawlessly. turned off NVIDIA GPU and now battery life time is more than 3hr.

I will assume you have a fresh install and have not installed nvidia drivers OR ironhide.

(If you installed ironhide please do a fresh install.This will save time and frustation.)

Instruction for installing Bumblebee to turn off discrete GPU and enable only when required

  1. Type the following in terminal,

    sudo add-apt-repository ppa:bumblebee/stable then sudo apt-get update

  2. To install Bumblebee using the proprietary nvidia driver:

    sudo apt-get install bumblebee bumblebee-nvidia

  3. Run following

    sudo usermod -a -G bumblebee $USER

  4. Reboot.


If you just want to disable nvidia card, no need to learn followings

Usage Instruction :

To run a program with nvidia card, use optirun command prefixed in terminal. Like to run glxspheres with nvidia card type

optirun glxspheres

To run firefox type : optirun firefox &

Note: If you intend to run 32-bit programs like Wine and using Ubuntu 11.10 Oneiric or later, install 32-bit libraries with: sudo apt-get install virtualgl-libs:i386 libgl1-mesa-glx:i386 libc6:i386

Linked Questions:

How well will Nvidia Optimus cards be supported in 12.04?

How well do laptops with Nvidia Optimus work?

Can't use nvidia card/driver on optimus notebook

share|improve this answer
    
In this line: "sudo usermod -a -G bumblebee $USER"; On $user you have to put the name of your user, not "$USER" –  Carlos Soriano Sánchez May 9 '12 at 11:18
    
No its not required as $USER is an environment variable that returns current user.check with sudo echo $USER or echo $USER –  Web-E May 9 '12 at 11:27
    
Oh, sorry, I fixed it because in the web page of bumblebee say that it has to be changed by your user name. –  Carlos Soriano Sánchez May 9 '12 at 22:48
    
Tnx For The Help, Tnx A Lot, Now It Seems Through this Manual I Can Use My nvidia Card But Not In Default, And I'm not able To Use It For 3D Effects And Using In While Kubuntu Or Any KDE Pre-Installed OS Is In Use, How can I Fix This, Make My system Know That Intel Should Not Be Used, nVidia Is Intended, And If I Want To Use GPU computing Staff And Things That Need My Graphic Card Cores What Should I Do Then...? –  T0M XeOn LuCiFeR May 12 '12 at 15:16
    
And ALSO I Was reading About Iron Hide It Says that We Can Simultaneously be Using Both Graphics, So What Problems It Can Cause, When u Said It Can Cause Complications & ... –  T0M XeOn LuCiFeR May 12 '12 at 15:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.