Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I get mp4 video to playback normal. They skip and look horrible. I was able to get them to playback on Fedora using a different setting with smplayer but nothing seems to work with Ubuntu.

share|improve this question
Have you tried the application called VLC? It is available from the Ubuntu Software centre. – Sun Dial May 9 '12 at 10:53
Yeah, I tried VLC and played with settings A LOT and nothing worked out. When I got it to work on Fedora all I had to do was set H.264 codec to skip always. – pypie May 9 '12 at 10:59
Can you give us a better idea about your machine specs, specifically cpu and graphics? It's possible you might be able to enable hardware acceleration. – Veazer May 9 '12 at 13:30
This question appears to be abandoned and unanswered, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. – Eliah Kagan Jan 5 '13 at 9:49
Graphic card or RAM. – Shaharil Ahmad May 19 '13 at 15:24

Playback of cpu intensive video can be problematic if your CPU is not fast enough.

Smplayer is a frontend for mplayer. You can install mplayer and start the playback from the console. Reading the console output is mostly very helpful. You can change the output driver. Changing you Graphics-driver can also sometimes solve the problem.

share|improve this answer
Ahh, somewhere to start I gues. Says my cpu is to slow and a lot of other stuff. Looks like I'll have some fun. – pypie May 9 '12 at 11:13

I faced this problem, too. I came to the conclusion that gxine was best for this. (smplayer kept delaying the video further and further.)

share|improve this answer

ffplay it from a command line, although I have some issues with the subtitles. You can try puppy linux, no lags and it works fine with the Gnome player, except that you may have the HDMI audio issues... VLC did not solve it for me either...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.