Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Well, I want to install the two EA games that arrived in the software Center recently. But these packages seem to be missing as in the following picture:

I've tried to update the sources, and tried to search manually but no luck . And I've tried installing them using the terminal also.

Despite the fact that they are online games, how can I fix this?
I am on Ubuntu 12.04.

share|improve this question
My understanding is that they're currently only available for 12.04. Also, are you looking in the "For Purchase" section? You can get there by clicking the arrow next to All Software. – Marius May 9 '12 at 7:01
@Marius: yes , I am on 12.04. And no, I can't find it there also. – Binarylife May 9 '12 at 7:08
Bug report it. It's broken for me too. They appear if you look in the right place, but they are not in the search. – gecko May 9 '12 at 9:29
@gecko : Where should I look? – Binarylife May 9 '12 at 10:52
up vote 1 down vote accepted

While you can still play the games (as OrangeTux pointed out), it would be ideal to install these through the Software Center, so that EA can see the strength of the Ubuntu platform.

For now, that seems to be impossible for many users, but you can subscribe to the bug report on Launchpad.

share|improve this answer

The only thing the installation does is creating a shortcut to the games. The games are browsers games, so no installation is needed.

Here are the links:

Command and Conquer

Lord of Ultima

share|improve this answer
I know they are just launchers for online games. And I can make them manually. But why I can't find them in the Software Center? This is my problem. Thanks btw – Binarylife May 9 '12 at 8:14
This doesn't really help, it just bypasses the software center and EA then has no way to measure the success of trying USC as a distribution platform. Better the fix the actual problem so users who try it can be counted! – Jorge Castro May 10 '12 at 21:12

Search works fine here - Lord & Command respectively

share|improve this answer
Does not work for me ,actually there are other users facing the same problem, as they are saying in OMG Ubuntu post. – Binarylife May 11 '12 at 12:54

Try running the Update manager, if there doesn't appear to be any update click Check. After installing those updates go back to Ubuntu Software Center and the games should be there.

Anyway, as they have already said, there are just icons which redirect you to the website.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.