Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I set the network proxy as per the system settings GUI but this is not picked up by ubuntu one or update-manager - I just get failed to update repository information.

Even apt doesn't work. I then added a proxy into the config file manually in /etc/apt/apt.conf.d/ with:

Acquire:http { Proxy "http://whatever:1234"; };

I could then run apt-get successfully. But still not the two packages above. Why aren't the system settings working?

share|improve this question
    
Did you click on apply system wide ? –  guntbert Sep 29 '13 at 20:13

1 Answer 1

Backup this file.

sudo cp /etc/apt/apt.conf /etc/apt/apt.conf.bak

You can try editing the file:

sudo gedit /etc/apt/apt.conf

Add lines like:

  • For proxy without authentication.

    Acquire::http::proxy "http://proxy_server:port/";
    
  • For proxy with authentication.

    Acquire::http::proxy "http://username:password@proxy_server:port/";
    

Same way for other protocols like ftp, https etc.

Then run

sudo apt-get update.

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.