Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

window (title and icon) sometimes doesn't appear. As a solution to this, I have to logout and login again. Is there something wrong with my system? How to make sure that this doesn't happen again?

window

share|improve this question

3 Answers 3

up vote 17 down vote accepted

You can try couple of things:

  1. Resetting Unity

    Hit Alt+F2 and run:

    unity --reset
    

    Please note that this will "reset profile parameters in compiz and restart the Unity shell with default settings." That is to say, you may lose some of your customizations (if you've made any), including to the notification area.

    However, this is still much safer than CCSM (described below), and it is a good idea to reset Unity before implementing a CCSM-based solution.

  2. CompizConfig Settings Manager

    Install CCSM (If you don't already have it) by running following command in terminal

    sudo apt-get install compizconfig-settings-manager
    

    Open it by searching "CCSM" in Unity dash.

    enter image description here

    Once open, Click on the "Effects" category and make sure that "Window Decoration" is enabled.

    enter image description here

Tip:

When window borders are missing you can still perform some basic functions like, minimise, maximise and move. Press and hold Alt and right click on the window.

share|improve this answer
    
thanks for the tip!! –  db42 Jul 11 '12 at 11:22

Type the following in terminal:

nohup gtk-window-decorator --replace &

Hopefully, the above command should solve your problem.

share|improve this answer
1  
It solves the problem for me, but only temporarily. The process remains active and has to be backgrounded (if you want to use the terminal for anything else). If it gets killed, window borders are gone again. –  Confusion Jul 11 '12 at 6:22
1  
To keep the process running in background and allow to close the terminal I use this command: nohup gtk-window-decorator --replace &. Then you can safely close your terminal window. –  Lynch Dec 28 '12 at 21:57
2  
This should be marked as the correct answer! –  HDave Jan 3 '13 at 22:54
    
Or press Alt+F2 and run the command there. –  Nathan J. Brauer Jan 29 at 17:54

I just disabled Window Decoration and restarted the PC since Unity seemed not working anymore (and to be sure that everything restarts properly). Then I re-enabled Window Decoration and restarted again (for the same reason).

After that, Window Decoration works again!

share|improve this answer

protected by Community Aug 9 '12 at 19:42

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.