Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to enroll my nodes in my MaaS cluster. I am doing this by booting them from the 12.04 installation CD, and choosing the MAAS installation option.

I'm only trying to set up one node right now. When i do the enrollment process, the node shutsdown, and I see 0 nodes on the MAAS homepage of my master node.

I tried adding the node from the MAAS web gui, when I do this, I get an error on the page that says:

Unable to create Node: Unknown problem encountered with the Cobbler server.

In the cobbler.log is the following:

Tue May  8 20:43:47 2012 - DEBUG | REMOTE maas authorization result: True; user(?)
Tue May  8 20:43:47 2012 - INFO | find_items; ['system']
Tue May  8 20:43:47 2012 - INFO | Exception occured: <class 'cobbler.cexceptions.CX'>
Tue May  8 20:43:47 2012 - INFO | Exception value: 'dns-name duplicated: node1'
Tue May  8 20:43:47 2012 - INFO | Exception Info:
File "/usr/lib/python2.7/dist-packages/cobbler/remote.py", line 1944, in _dispatch
return method_handle(*params)
File "/usr/lib/python2.7/dist-packages/cobbler/remote.py", line 910, in xapi_object_edit
self.modify_system(handle, 'modify_interface', imods, token)
File "/usr/lib/python2.7/dist-packages/cobbler/remote.py", line 827, in modify_system
return self.modify_item("system",object_id,attribute,arg,token)
File "/usr/lib/python2.7/dist-packages/cobbler/remote.py", line 820, in modify_item
return method(arg)
File "/usr/lib/python2.7/dist-packages/cobbler/item_system.py", line 644, in modify_interface
if field == "dnsname"             : self.set_dns_name(value, interface)
File "/usr/lib/python2.7/dist-packages/cobbler/item_system.py", line 288, in set_dns_name
raise CX("dns-name duplicated: %s" % dns_name)

It seems like there is a chicken and egg game being played between dnsmasq's DNS server, and the cobbler's hostname database -- this is just a guess on my part.

Here is the contents of dnsmasq.leases: the MAC addr of node1 is 00:03:47:22:1c:e2

dbuttric@sid:/var/lib/misc$ more dnsmasq.leases 
1336531172 00:03:47:22:1c:e2 192.168.5.119 * *
1336530695 00:90:27:32:3b:53 192.168.5.148 node3 *
1336530676 00:90:27:18:f2:0b 192.168.5.242 node2 *

How can I delete hostnames from cobbler, and retry my node adding activities?

Here is more: I can successfully register a node and the MAAS server shows that it has 1 node registered in it.

5 minutes later, I go back to the MAAS web gui, and it reports 0 nodes. I have not looked at error logs yet, but what can cause this to happen?

Should I just try re-installing the master node?

share|improve this question
    
So, I have been pretty unscientific about this. I took all the advice here, and did it. Now nodes are getting added to my cluster. I think the cause here was that I was missing the maas-enlist and tftpd-hpa packages. If those had been installed, I would not have needed to use the 'cobbler system remove' command. Thanks for all the help here. –  David Buttrick May 20 '12 at 17:50

4 Answers 4

up vote 4 down vote accepted
+50

I have the same problem and found solution: you need to install maas-enlist & tftpd-hpa package.

sudo apt-get install maas-enlist tftpd-hpa

then re-run sudo maas-import-isos -u

share|improve this answer
    
Can you add a url or some commentary on why it worked? –  Jeremy Hajek Apr 15 '13 at 19:46

Just do:

# cobbler system list

# cobbler system remove --name="one of the names in list"

# etc. etc.

share|improve this answer

Have you enlisted any node with the same hostname (node1) before? If so, then you should probably enlist the new node with another hostname.

If that's not the case, and you don't have any other nodes in MAAS with the same hostname, you will need to find out why is this duplication in cobbler. For that you could do:

sudo cobbler system dumpvars --name "XYZ" | grep node1

That will help you find out which system node has that hostname in use and you will need to remove it. Once you find out which one is it, then you just do:

sudo cobbler system remove --name "XYZ"

And then try to enlist again.

Hope this information helps.

share|improve this answer
    
How do I find out what "XYZ" is? Is #cobbler system list the answer? –  David Buttrick May 20 '12 at 16:55
    
Yes! sudo cobbler system list Will give you the list of systems in cobbler –  Andres Rodriguez May 21 '12 at 15:50

Your question may be linked to MAAS node install shutdown error when installing from CD-ROM

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.