Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I used SoundJuicer the first time in 12.04, it worked correctly. When reading the second CD, it failed completely with the message: "SoundJuicer could not read the track listing on this CD. Reason: Cannot access CD: The specified location is not mounted".

Which is odd, since I am getting there through the GUI file system.

Is this a known bug (but is somehow not searchable using the exact error message, either as a quoted string, or as the list of tokens)? Is there some other search term that I should have used? I'll admit to being a newbie Ubuntu user, but I use RedHat at work, and often have to debug system level events-- those are easy to find via the error string. Am I wrong to expect otherwise here? Should I have searched the SoundJuicer site?

I sent a "report" (is that ubuntu-bug? I can't find that in my process table in the system-monitor-- is it for some reason not listed?), but thought that instead of waiting on an answer, I'd try to find a solution without waiting since there was a (remarkably) similar bug in 11.10. The core-dump is "helpfully" hidden (and I cannot seem to copy from the report in any case), but I can report that the problem originates in gvfsd-cdda.

share|improve this question
up vote 0 down vote accepted

It is a bug of SoundJuicer that they won't solve. You have to close SoundJuicer and start it again to make it work.

Excuse me if I don't post a link to back my information, but I struggled with this for a long time. Now I just restart it after inserting a new CD.

share|improve this answer

Did you confirm the CD you inserted have no problem? Isn't the CD corrupted? If this problem happens randomly, check whether your CD-ROM drive works properly, or try to clean the drive. If you are frequent CD/DVD drive user, pick-up part of CD-ROM drive may be wasted down.

share|improve this answer
Drive reads correctly in file-system (displays correct number of tracks), and vlc totem. But totem fails to connect w/CD-ID databases, and doesn't save without much extra programming. – Derrell Durrett Jun 5 '12 at 21:45
I can confirm that I'm having the same issues with sound-juicer with a CD that even (after a lot of failed attempts) was readable in Rhythmbox. Brand new CD btw :) – benjaoming Jun 8 '12 at 23:56
I solved my Rhythmbox problems by deleting ~/.gstreamer-0.10 – benjaoming Jun 8 '12 at 23:57
Rhythmbox reads fine. But it says to use SoundJuicer for importing a CD, so I'm stuck (without writing my own version of SoundJuicer, which seems silly since it was working so well for so long (before 11.04). – Derrell Durrett Jun 9 '12 at 18:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.