Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two completely separate drives in my computer. One has Windows7 and that was already installed. I installed Ubuntu on my other drive specifically for Ubuntu, and now GRUB boot-load shows up no matter what order my boot priority is in my BIOS. This never happened before, and They both kept on their own drives. What happened? The only way for me to get into Windows anymore is for GRUB boot-loader to load up and to select the Windows7 loader listed towards the bottom of the list(on a completely separate drive. I want them separate hence the reason I have two separate drives.

I have tried to repair the Windows Boot-Loader with the installation disc, but it does not even show up in the list. I think Ubuntu installed GRUB into the Windows Boot partition maybe?

Also, I have unplugged the Ubuntu drive and re-booted. The Windows 7 will not start. After bios int, computer just sits. What happened?!

share|improve this question
    
Have you tried the repair disk with the ubuntu drive unplugged? If i'm reading correctly, it doesn't seem like it. –  czifro May 9 '12 at 1:30
    
Post is so failed to mention the exact problem.Separate boot loader for different OS is not possible but you can select from a list of options.But you have to connect both drive during installation.You installed Ubuntu after windows,so the last installed one appear the first on list.By reading your post 15 times,what I understood that everything is clear and done well as normal. –  beeju May 9 '12 at 1:37
    
I used to have ubuntu and windows7 on two separate drive, and whatever order I had them in BIOS boot order, they would boot. Now my Windows7 wont even boot when the ubuntu drive is unplugged. I know it's possible to have the two drives completely separate. I AM USING TWO PHYSICALLY SEPARATE DRIVES! NOT PARTITIONS! –  aknewhope May 9 '12 at 1:49
    
I am having the same issue. It started happening after I installed Ubuntu behind a Windows 7 installation. My machine has UEFI enabled and I think this has something to do with the problem. I can't even hit F2 to enter the BIOS or boot from a CD/DVD ROM any longer. Sucks! Ubuntu 12.04... are you using UEFI and Ubuntu 12.04? –  bbqchickenrobot Jun 14 '12 at 19:08

1 Answer 1

It sounds like you already had the Windows boot loader on one drive, and when you installed Ubuntu, chose to install grub to the same drive, and never put a boot loader on the second drive. If you want to put the Windows boot loader back, you need to boot the Windows install cd, go into the recovery console and use the FIXMBR command.

share|improve this answer
    
I tried the FIXMBR command from the command line and says no such command. –  aknewhope May 9 '12 at 2:01
    
You need to do it from the recovery prompt on the Windows Install CD. –  neon_overload May 9 '12 at 3:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.