Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

A similar issue is found elsewhere but only with 32bit programs.

I have this problem when trying to run clementine - which is 64bit, i checked the binary i have - and ubuntu-one-control-panel-qt

I'm starting to feel like I've tried everything. Is there a way to restore my qt installation to some kind of default state?

I think this might have happened after I uninstalled Rhythmbox with 'sudo apt-get remove rhythmbox'. I've since reinstalled rhythmbox though, and thought any removed dependencies would be reinstalled with apt....

EDIT: this is my apt history log: https://gist.github.com/2646562

Line 215 is when I first installed Clementine. It was obviously working at this point. Removing Rhythmbox at line 305 doesn't look like it did too much damage. Yet that is the point when it stopped working, as most of the rest of the log is me trying to fix Clementine.

Just to repeat: I don't think any Qt apps are working on my installation. I'm about to research how to completely remove and reinstall Qt, see if that's a hopeful avenue.

share|improve this question
add comment

2 Answers 2

The rhythmbox package is a dependency of the ubuntu-desktop package, which is used to ensure you have the basic desktop components.

If you forced the removal of Rhythmbox, it would have also forced the removal of ubuntu-desktop, which might have let some other critical desktop components be removed. Reinstalling Rhythmbox wouldn't restore the other packages that needed to be removed to complete that first operation.

You might be able to fix things up by reinstalling ubuntu-desktop with the following command:

sudo apt-get install ubuntu-desktop

If that doesn't help, please provide a bit more information about what changes you made to your system between when things worked and when they stopped working.

share|improve this answer
    
'ubuntu desktop is already the newest version'. I'm trying to think of what changes I made before I started having problems (It's a new install so lots of changes happen all the time currently). The problem was I had both Clementine and Rhythmbox installed. The sound menu in the menubar had applets for both these apps, but I wasn't using Rhythmbox. I searched for a solution to remove the rhythmbox applet and somebody suggested simply removing rhythmbox. I have edited my question with a link to my apt history.log and the section about rhythmbox. I can't think why apps can't find Qt... –  Phil May 9 '12 at 16:40
    
Sorry for the double post, I hope you see this @James. I still have this problem and haven't been able to find anything that works. I'm still unable to use any Qt apps. Can you help me / should I ask again on this site? –  Phil May 11 '12 at 22:15
    
You could try installing the 32-bit libQtSQL with the command sudo apt-get install libqt4-sql:i386 and see if that helps. I've got no idea why you'd need the 32-bit libraries to run the Ubuntu One control panel though. –  James Henstridge May 13 '12 at 10:34
    
Tried that. it's getting to the point where I'm considering backing up and starting form scratch... really don't want to do that though :(. I might try reinstalling ubuntu-desktop? –  Phil May 16 '12 at 0:29
add comment

I've got the same issue when installing Time Doctor (not from repos) on fresh install of Ubuntu 13.10 GNOME x64.

Your comments made me to investigate and do this:

sudo apt-get install libqt4-sql
sudo apt-get install libqt4-gui

After that the error did not occur.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.