Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Background

(This problem does not occur in Unity 2D)

When moving a window around, and putting the cursor to the top of a screen, the orange box expands across the screen and you let go and the window goes full screen.... At least, it's supposed to.

When I'm NOT in Unity2D (i.e. Unity 3D or simply "Unity" as it shows when I log in), I can put the window full screen on my Right-Side monitor, but if I push the window to the top of the left monitor and let go, it snaps to Full-Screen on the RIGHT monitor !!!!!

It's really frustrating, because of course the whole purpose of having two monitors is to be able to view different things at the same time.

Question

Does anyone know what is causing this?

I feel like maybe it's accepting the right side monitor as the "Primary" or something like that. It only occurs sometimes, not constantly. It only started doing it since the update to 12.04. Also, Compiz process is running and taking a LOT of my processor, even if the computer is doing nothing. My CPU used to idle at around 30-31C, but now just sitting there, it's around 39-41C....12.04 is sucking big time right now in my opinion (not worth much).

Thanks for the input!

share|improve this question
add comment

3 Answers

Solution

I figured it out. Like Pauk said, it has to do with different resolutions.

It only occurs when trying to move a full-size window from large monitor to small monitor.

To solve the problem:

Resize the window in the large monitor so it is smaller than what would be full-screen on the smaller monitor (i.e. the window will fit in the smaller monitor without touching any edges).

Next, drag it to the top of the smaller monitor and release to make it full screen (or drag it to the smaller monitor and "maximize" it).

Like Miceterminator said, you can also drag to the side.....just do something to the window is SMALLER than full-screen of the smaller monitor.

Discussion

So the problem is we are trying to fit a large window (1920x1080 for me) onto a smaller (1600x900 for me) "canvas" so to speak. That explains why it pops back over to the larger monitor. Simply making it small enough to fit on your "smaller canvas," then maximizing it to fill completely, seems to be the solution.

I'm glad we got THAT figured out!

share|improve this answer
    
I experienced this a couple of times in the past week. Currently, my monitors are the same size/resolution - I just made the window size quite small and it seemed to work! Good tip! –  trent Jul 10 '12 at 1:45
1  
That's a workaround, but what's the solution? What the window manager does is blatantly wrong as it flat out refuses to shrink the window if two conditions are met: 1) the window is wider/higher than the monitor you try to throw it on and 2) another monitor is wider/higher than the window. If either of these conditions isn't met, it will work as expected. What is the root cause of this "feature" and how can it be turned off? –  pluma Oct 25 '12 at 10:00
    
Agreed. The work around is fairly obvious once you understand what is happening. But the problem is IT SHOULDN'T be happening. The whole point of dragging it to the top of a screen is to fit the window to the size of that current screen (aka maximizing). Whether "maximimizing" grows or shrinks the window should not be our responsibility. –  thefreeman Feb 8 '13 at 16:21
add comment

I noticed that happens when you have different resolutions on your monitors. For example, I have laptop with 1366x768 resolution and external monitor in 1920x1080. When you try to maximize (either by snapping it to top edge or via maximize button) and the window height is greater than screens vertical height (on my laptop) it will maximize on the screen with higher resolution (on external monitor).

share|improve this answer
1  
Yes, I have two different resolutions: 1600x900 and 1920x1080 Any idea how to fix it? –  Bradley Peterson May 9 '12 at 15:36
add comment

I would like to point out, that the window snapping is quite glitchy on my dualhead setup as well. However, when compiz choses the wrong monitor for the full screen application I try to snap it to the side of the monitor where I want it (half of the monitor with the window) and when I try to maximize it again on the monitor, it works.

Also be aware of the mouse barrier between the two monitors sometimes the window moves on the other monitor but the mouse stays behind. So if you try to maximize it, compiz uses the monitor on which the mouse is located, so it snaps to the wrong monitor. As the barrier is only to access the launcher on the second monitor I used compiz-config-settings-manager (ccsm) to disable the barrier (I believe you can find it under the unity plugin settings).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.