Ubuntu versions prior to 12.04
Currently there is no method to install Gimp 2.8 on any version below 12.04.
In terms of is it possible ...
Unlikely for the following reason:
The dependencies of the latest versions of Gimp require a-lot of the latest underlying libraries that you will not find by default in any version below 12.04. Thus, you will need to recompile and rewrite portions of the code to get it to compile. The further away you get from 12.04, the larger the change required.
A maintainer of the Gimp package (ppa:matthaeus123/mrw-gimp-svn) mentions in the description that it needs the latest Gnome-3 PPA as well as some other testing libraries. Both of these will not install on gnome-2 environments (below 11.10). Looking at the dependency lists for 12.04 version of Gimp, these are also not available in 11.10.
Will it ever be available in a PPA for versions below 12.04? Its probably safe to say unlikely unless there is an enterprising developer out there who wishes to port this to this.
Until then, UbuntuForums has an interesting thread on how to compile from source.
Thus - if you definitely want Gimp 2.8 - look to installing 12.04 + one of its many desktop environments.