Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual-screen setup with mu laptop screen as primary and my LCD screen as secondary placed over the laptop screen. On my laptop screen I have a top-panel at the top of the screen and docky at the bottom. When the LCD screen is off/disconnected, there is no problem when maximizing the window on the laptop screen, but when it is on, the top-window border gets hidden behind my top-panel. How can I get it to only maximize to the panel and not below it? it is quite annoying that I cannot get to the min/maximize/close window buttons etc.

share|improve this question
    
OK I need this answered too - and moving the panel or deleting it or auto-hiding it is NOT an answer. The top screen in my case is a 40" TV on a wall, and I don't want to have to crane my neck every time I want to adjust the volume. Why is it so hard to make the stupid panel stay behind the windows? –  Hank Jan 9 '11 at 2:04
add comment

1 Answer 1

I have exactly the same physical monitor setup and the same annoying problem!

I kind of solved this by dragging the top-panel to the top of the LCD screen.

BUT to be able to move the top-panel up to the top of the LCD screen you first need to untick the "Expand" checkbox in the panels properties (right-click on the panel to get to them).

Then you can grag & drop the panel upto the top of your LCD screen and when its docked there, it won't overlap over your normal apps windows.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.