Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Im using Ubuntu 12.04, and my laptop is an Asus G60J.

Specifications:

Ubuntu 12.04 64bit

Intel i7 720qm

Nvidia gtx 260m

4gb RAM

The laptop always start with the keyboard backlit On. The hotkeys sometimes work, sometimes don't. Generally they always work to turn on the lights, but it is very hard to turn them off. It is really annoying because when the laptop suspend the keyboard remains turned on.

I would like to know what file manage the FN events so I can try to figure it out. Any kind of help is appreciated.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You can manually set the brightness value (between 0 and 3) of the keyboard with the file:

/sys/class/leds/asus::kbd_backlight/brightness

The simplest is first to give you the right to modify it:

sudo chmod 777 /sys/class/leds/asus::kbd_backlight/brightness

And then change the value, for instance to turn it on:

echo 3 > /sys/class/leds/asus::kbd_backlight/brightness

Or turn it off:

echo 0 > /sys/class/leds/asus::kbd_backlight/brightness

You can set a global shortkey (eg Fn + F3 or F4) for those commands, I'm on KDE then cannot help you for this, just have a look on the settings.

(Note: Maybe the maximum value is not 3 in your case, have a look at /sys/class/leds/asus::kbd_backlight/max_brightness.)

share|improve this answer
    
Thank you, worked like a charm! max_brightness is 3 but the fn keys still don't work.. But that is not really necessary. Greetings –  NewK Jul 29 '12 at 14:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.