Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The title describes my problem. On Ubuntu 11.10 Multi-touch worked fine on my Apple Magic Trackpad. Now i have only "ONE-FINGER-Control". Scrolling is only possible on the right side of the pad with one finger. Three or four fingers are also not working any more (four fingers to to get the Dash or three fingers to move a window). What could I do to get this working again?? (on 12.04)

share|improve this question
Have you tried re-installing all of your drivers yet? – TenorB May 8 '12 at 17:53
no, i didn't install any driver on 11.10. I don't know what to re-install. I only did the pairing by "Using the Commandline" (from because there exists a bug: – Marian Lux May 9 '12 at 6:04
up vote 3 down vote accepted

To get this working I had to install utouch:

apt-get install utouch

For details, read:

share|improve this answer
THX! It works now for 3 and 4 fingers. The only thing that does not work is two finger scrolling. On the mouse settings I can't set 2 finger scrolling, because my notebooks touchpad does not support 2 finger scrolling. So this option is disabled. Any ideas to get this separately (touchpad for notebook with sidescrolling and apple magic trackpad with 2 finger scrolling) working?? – Marian Lux May 30 '12 at 7:50
That ubuntu wiki page does not at this moment exist... – drevicko Jul 10 '12 at 5:02

I was able to enable two-finger scroll by using the xinput command. xinput with no arguments shows all the input devices on the system. The Apple Trackpad was device 9 in my list; I used command xinput list-props 9 to see all the properties for the Apple Trackpad. I then disabled the edge scroll using the Mouse and Touchpad menu in System Settings, then enabled two-finger scrolling (282) using xinput.

xinput set-prop 9 282 1 1

The change is NOT reflected in the System Settings --> Mouse and Touchpad settings, but everything now works.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.