Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was running Ubuntu 11.10, and upgraded to 12.04. After the system rebooted, it began exhibiting the following behaviour:

1) It loads the BIOS. I can access the BIOS menu, so I can select what piece of hardware the computer boots from if I need to. 2) The screen turns purple. 3) The screen turns black.

Mashing ESC, DEL, etc does nothing after phase 1; in fact, the keyboard and mouse are totally unresponsive. I cannot even turn numlock off and on.

I tried loading from a Super Grub 2 disc, but while it can detect some two dozen kernels, none of them seem to load properly. I am booting from a Live CD now, but I'm not sure how I should go about fixing this.

share|improve this question

closed as off topic by fossfreedom May 15 '12 at 8:21

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I would try booting to the livecd.. If that works, I would identify the boot partition with sudo fdisk -l , then I would mount it with mount /dev/<boot_part_e.g., sda1> /mnt, then I would run sudo grub-install --boot-directory=/mnt/boot /dev/sda , per help.ubuntu.com/community/Grub2 –  Shannon_VanWagner May 8 '12 at 16:50
    
Booting from a livecd works fine, sorry I forgot to mention that - in fact, I'm booting from it now. I went ahead and tried installing grub as you suggested, going to reboot now. Fingers crossed. –  quindraco May 8 '12 at 16:59
    
Tested thoroughly; doing this appears to have had absolutely no impact whatsoever. Behavior is 100% identical to before I reinstalled grub. –  quindraco May 8 '12 at 17:15
    
That's great that the LiveCD works.. Ok, so I'm thinking it might be either the initrd.img or a needed kernel parameter. To test for the initrd.img, I would copy one over from the 11.10 installation into the /boot directory and rename it to whatever the current one is (rename the current one with .old or something first to back it up). goo.gl/Fhx9m As for the kernel paramaters, there are a few ways to do it but I would chmod 644 the /boot/grub/grub.cfg and put acpi=off, nomodeset, (try each one, and maybe more) at the end of the Linux kernel line. Prob try kern par changes 1st. –  Shannon_VanWagner May 8 '12 at 18:37
1  
Welcome to Ask Ubuntu! This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  Jorge Castro May 15 '12 at 1:37

Browse other questions tagged or ask your own question.