Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this script (or rather a set of commands which has permission to execute) to enable two finger scrolling and two finger tap = right click The script is located in /home/gaurav/Multigesture/multigesture.

When I run the following command in terminal, two finger scrolling and two finger tap = right click start working. I have to run this command each time I boot my laptop.

"/home/gaurav/Multigesture/multigesture"

So I put this command in the startup applications so that I dont have to run the command each time I boot but when I reboot two finger scrolling is not working, only two finger tap = right click works.

What could be the problem, If the command works fine from the terminal then how come it is working partially when i put it into startup applications.

Here is the content of the script

xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Two-Finger Scrolling" 8 1 xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 8 1 1 xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 32 10 xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Width" 32 8

PS. the file which has all the commands (script's) name is multitouch

share|improve this question

7 Answers 7

up vote 1 down vote accepted

I came across this fix which works just fine for me and recognizes two fingers (scroll and right click). Just download this package -->

https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/308191/+attachment/1735234/+files/synaptics-dkms_1.0.0_all.deb

As per comments on the bug report, this package has worked for most of the multitouch touchpads including Acer. Three finger touch didn't work for me.

read comment #115 and #116 at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/308191/+index?comments=all

share|improve this answer

You can make a script load at boot up by making it an init scripts. Here is a how-to: Ubuntu bootup howto

share|improve this answer
    
I think this is the same process that @Manish has suggested which doesn't seem to work. –  Gaurav Butola Nov 15 '10 at 17:40

Not sure if this works either but

add this line to /etc/rc.local (before "exit 0"):

/home/gaurav/Multigesture/multigesture

share|improve this answer
    
looks like /etc/rc.local doesn't run on the startup. –  Gaurav Butola Nov 16 '10 at 10:46

Here is an howto for setting up scripts for touchpad: ubuntu community documentation EEE PC. The section on multi-touch alnswers your question on runnning scripts at boot.

share|improve this answer
    
That is the same thing I am doing mentioned there. –  Gaurav Butola Nov 16 '10 at 10:56

Not sure if this works but

Copy the script to /etc/init.d/

Like

sudo cp multitouch /etc/init.d/multitouch

And then update the script to work in runlevel 2345

sudo update-rc.d multitouch defaults

and then enable this command using rcconf

sudo rcconf

Select the multitouch options using space bar and hit OK

reboot the system

You might need to install the package rcconf

sudo apt-get install rcconf

Hope this works


This tutorial gives a better insight on how update-rc works. http://www.debuntu.org/how-to-manage-services-with-update-rc.d

Google for runlevels if you want to gain more knowledge.

share|improve this answer
    
:( when I put it into startup apps, command partially works but from the above mentioned method the script doesn't seem to run at all, whereas when I do sudo "/etc/init.d/multigesture" everything works fine. –  Gaurav Butola Nov 15 '10 at 17:37
    
I added the answer. Check the sudo update-rc.d multitouch defaults command. –  Manish Sinha Nov 17 '10 at 9:27

Maybe try a simple upstart startup script. Create a file in /etc/init with the .conf extension. In the file put:

start on started tty1

exec /home/gaurav/Multigesture/multigesture

share|improve this answer

Slowing the startup script maybe helps...

I've had a problem with conky because the xserver was not completely loaded when startup application started conky.

I resolved with:

#!/bin/bash

sleep 10 && conky;

you sould just change conky with your script name (and path) :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.