Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Apple macbookpro 5,3 and I have a 23' cinema display setup on the DVI port. I have the Nvidia X server set up to do TwinView and all is well other than I get the following error when login of my user account from a fresh restart.

none of the selected modes were compatible with the possible modes: Trying modes for CRTC 351 CRTC 351: trying mode 3360x1200@50Hz with output at 1440x900@50Hz (pass 0) CRTC 351: trying mode 3360x1200@50Hz with output at 1440x900@50Hz (pass 1)

Here is what my config file looks like located in /etc/X11/xorg.conf

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 295.33 (buildd@allspice) Fri Mar 30 15:25:24 UTC 2012

Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" 0 0 InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer" Option "Xinerama" "0" EndSection

Section "Files" EndSection

Section "InputDevice" # generated from default Identifier "Mouse0" Driver "mouse" Option "Protocol" "auto" Option "Device" "/dev/psaux" Option "Emulate3Buttons" "no" Option "ZAxisMapping" "4 5" EndSection

Section "InputDevice" # generated from default Identifier "Keyboard0" Driver "kbd" EndSection

Section "Monitor" # HorizSync source: edid, VertRefresh source: edid Identifier "Monitor0" VendorName "Unknown" ModelName "Apple" HorizSync 30.0 - 75.0 VertRefresh 60.0 Option "DPMS" EndSection

Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" BoardName "GeForce 9600M GT" EndSection

Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 Option "TwinView" "1" Option "TwinViewXineramaInfoOrder" "DFP-1" Option "metamodes" "DFP-0: nvidia-auto-select +1920+0, DFP-1: nvidia-auto-select +0+0" SubSection "Display" Depth 24 EndSubSection EndSection

share|improve this question

1 Answer 1

Have you tryed with: rm ~/.config/Monitors.xml Put that and reboot, if it doesn't work let me know. Perhaps it's a Driver problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.