Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After the upgrade to 12.04, networking is down. I can ping my router, but that's it. (This is a wired connection, not wi-fi).

Manually running /etc/init.d/networking restart does not help.

I don't know if it is connected, but I have also noticed 2 other issues:

  1. A popup comes up asking if I want to send an error report about a system program problem (aptd)
  2. In MythTV, sound and picture are no longer in sync (graphics seems slow and klunky, like the bad old days)

None of these issues are cured by shutdown / power-off, reboot.

Help please, my family are going to kill me :-O

share|improve this question
    
Could you verify your network setting and post them here? (it would be useful to know if you are using DHCP, fixed IP, fixed routing, etc.) You can get many information from the network settings, but you might want to run the following commands and post the outputs here too: sudo route -n and ifconfig –  Huygens May 8 '12 at 10:37

1 Answer 1

If you can ping your router then your network is not really down. I assume the problem is that you cannot access the Internet, correct?

This sometimes happens to me and I seem to be able to recover by

  1. Unplugging the power supply for both my router and my ISP's cable modem.
  2. Restoring power to the ISP's cable modem and allowing it to power up and initialize.
  3. Restoring power to my router.

Have you tried that? (Assuming it applies in your situation.)

It would help us to answer if you updated/edited your question and provided more details as @Huygens has already requested.

Another thing you might try is running the following command in a terminal window:

dig www.askubuntu.com @8.8.8.8

The result you should get should look like this

irrational@BlueUbuntu64:~$ dig www.askubuntu.com @8.8.8.8

; <<>> DiG 9.8.1-P1 <<>> www.askubuntu.com @8.8.8.8
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 861
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.askubuntu.com.     IN  A

;; ANSWER SECTION:
www.askubuntu.com.  1942    IN  A   64.34.119.12

;; Query time: 46 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Tue May  8 18:21:34 2012
;; MSG SIZE  rcvd: 51
share|improve this answer
    
Thanks for all your help and suggestions. It turns out that the way DNS is handled has changed - and /etc/resolv.conf is now regularly nuked by NetworkManager. So I had to move my nameserver settings into the eth0 section of the interfaces file (I have a static IP) - now all is working. –  Chris Bamford May 10 '12 at 12:59
    
@ChrisBamford I believe the recommended way to proceed when you end up answering your own question is to (1) actually add your solution as a answer to your question, (2) wait 2 days, (3) accept your answer as the "best" solution. More is said about this in the last paragraph in this section of the faq. See the link to ask and answer your own question –  irrational John May 10 '12 at 21:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.