Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I wanted to try MAAS out so I installed the server in VirtualBox VM. After installation completion, nothing seemed to happen. I got "Internal server problem" when I tried accessing I already update and ran sudo maas createsuperuser but nothing seemed to change.

Looking at Apache2 log I found a lot of python error. At the end of the stack is

DBUSException: org.freedesktop.DBus.Error.Spawn.FileInvalid: Cannot do system-bus activation with no-user.

share|improve this question
@mateo_salta MAAS is ubuntu related. – Jorge Castro May 15 '12 at 17:16

Hi I had this problem too. In my setup it's the avahi-daemon that don't starts at boot. After sudo service avahi-daemon start everything runs fine.

share|improve this answer

I had the same problem using VMware vSphere 5.0. I solved it by installing build-essential, linux source and VMware Tools.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.