Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On Ubuntu 12.04 I use openbox with a single "gnome-panel" started. But after trying to configure my two screen in Xinerama mode I got additional rows of panels each time X restarted.

And despite I completely reverted to my one-screen-X-config

  • the gnome-panel displayed has 4 rows (4 at top sreen, 4 at bottom)
  • only the outermost row has content, the other 3 are empty
  • there is only one gnome-panel process running
  • some widgets appear 4 times, too, although they run only once
  • when I switch away from openbox using unity I am back to 1 row temporarily

What went wrong here? How do I undo that? Things that did not help:

  • rm -Rf .gnome2 .gconf/ .compiz-1/
  • pkill panel, and restarting it
share|improve this question
    
This is bug in gnome-panel, at least i think so. bugs.launchpad.net/ubuntu/+source/gnome-panel/+bug/1083811 –  albertsmuktupavels Nov 27 '12 at 22:26

2 Answers 2

up vote 12 down vote accepted

Run the following, apparently gnome3 stores configuration in binary form (I haven't read up on dconf enough to know where or why).

sudo apt-get install dconf-tools

Run: dconf-editor to edit the config.

Go to: org.gnome.gnome-panel.layout (it's pretty intuitive)

The defaults seem to be:

object-id-list     ['menu-bar', 'indicators', 'show-desktop', 'window-list', 'workspace-switcher']
toplevel-id-list   ['top-panel', 'bottom-panel']

I had to figure this out after I had some weird issue with gnome while trying to get my 2 monitors to work. Everything (menus, rows, clock, etc.) seemed to duplicate on the panel after every attempt to restart the X server. I should have took a screenshot but this is essentially what I had before I fixed it:

object-id-list     ['menu-bar', 'indicators', 'show-desktop', 'window-list', 'workspace-switcher', 'menu-bar-0', 'indicators-0', 'show-desktop-0', 'window-list-0', 'workspace-switcher-0', 'menu-bar-1', 'indicators-1', 'show-desktop-1', 'window-list-1', 'workspace-switcher-1']
toplevel-id-list   ['top-panel', 'bottom-panel', 'top-panel-screen1', 'bottom-panel-screen1', 'top-panel-screen1-0', 'bottom-panel-screen1-0']

As you can see, there's 3 of everything.

share|improve this answer
1  
That was a perfect solution and nicely described. Do you happen to know where the config is stored that I am editing with dconf-editor? a) I could edit that file with emacs, then and b) I have most files of my homdir in a git repository and thought I would be safe against such things now -- but it seems I missed the file where that is stored. –  towi May 9 '12 at 6:32
1  
I found this, but I don't have a $DCONF_PROFILE and I haven't been able to find the files, hope this helps: live.gnome.org/dconf/SystemAdministrators –  zechariah May 12 '12 at 18:27
    
your settings work, but note that clicking the "Set to default" leaves the value blank ([]) (at least on my 12.10) –  David Nov 9 '12 at 21:31
    
pkill gnome-panel and blank values will be magically restored. –  philcolbourn Apr 11 '13 at 5:33

Thanks to zechariah.

What about:

dconf reset -f /org/gnome/gnome-panel/layout/

That got rid of 3 of my four panels.

share|improve this answer
    
The multiple rows came back for me every time gnome-panel was started. This turned out to be because /etc/X11/xorg.conf defined an extra "screen". –  user18096 Jun 24 at 22:07

protected by Community Dec 7 '12 at 21:31

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.