Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am planning install Oracle EBS in one of servers running on Ubuntu (2.6.38-11-virtual #50-Ubuntu SMP Mon Sep 12 21:51:23 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux). Part of installation pre-requisite, following packages are mandatory to apply. How to apply following OS packages in Ubuntu?

gcc-4.1.2-14.el5.x86_64
gcc-c++-4.1.2-14.el5.x86_64
glibc-2.5-18.i686 (32-bit)
glibc-2.5-18.x86_64
glibc-common-2.5-18.x86_64
glibc-devel-2.5-18.i386 (32-bit)
glibc-devel-2.5-18.x86_64
libgcc-4.1.2-14.el5.i386
libgcc-4.1.2-14.el5.x86_64
libstdc++-devel-4.1.2-14.el5.i386
libstdc++-devel-4.1.2-14.el5.x86_64
libstdc++-4.1.2-14.el5.i386
libstdc++-4.1.2-14.el5.x86_64
make-3.81-1.1.x86_64
gdbm-1.8.0-26.2.1.i386
gdbm-1.8.0-26.2.1.x86_64
libXp-1.0.0-8.1.el5.i386
libXp-1.0.0-8.1.el5.x86_64
libaio-0.3.106-3.2.i386
libaio-0.3.106-3.2.x86_64
libgomp-4.1.2-14.el5.x86_64
sysstat-7.0.0-3.el5.x86_64
util-linux-2.13-0.45.el5.x86_64
compat-libstdc++-296-2.96-138.i386
compat-libstdc++-33-3.2.3-61.i386
compat-libstdc++-33-3.2.3-61.x86_64
elfutils-libelf-devel-0.125-3.el5.x86_64
elfutils-libelf-devel-static-0.125-3.el5.x86_64
libaio-devel-0.3.106-3.2.x86_64
unixODBC-2.2.11-7.1.i386
unixODBC-devel-2.2.11-7.1.i386
unixODBC-2.2.11-7.1.x86_64
unixODBC-devel-2.2.11-7.1.x86_64
kernel-headers-2.6.18-8.el5.x86_64
openmotif21-2.1.30-11.EL5.i3861
xorg-x11-libs-compat-6.8.2-1.EL.33.0.1.i386

With Regards, Sai

share|improve this question
1  
The demograph for this is far too low for you to get an answer here. Best advice you will get: you need to switch from Ubuntu to CentOS. bigbadonk420's answer might work but no-one here will be able to test it since we do not have a Oracle Technet or Oracle.com account and it will mess up our own systems. –  Rinzwind May 8 '12 at 10:10
add comment

3 Answers

While it is certainly possible to get Oracle PBS to work under Ubuntu, i'm afraid you are using the wrong Linux distribution here. If you read the fine print Oracle does only officially support Red Hat Enterprise Linux. Until Oracle starts to support Ubuntu you might be better served with it.

share|improve this answer
1  
Support or not, it can be done. Not easy, but it can be done e.g. otac.isa-geek.net/blog/2008/01/19/… –  arochester May 8 '12 at 9:22
    
Thanks for your feedback. Yes I know Oracle EBS is certified on RHEL, OEL and SLE. But I am trying to install in Ubuntu. –  Sairam May 8 '12 at 9:24
1  
@arochester 2008 is long gone... Ubuntu made a transition from gnome to Unity and lots of the software underneath got changed. The installation in the link is never going to work on 12.04 (or even 11.10 or 11.04) –  Rinzwind May 8 '12 at 9:43
1  
So you know that this software is NOT supported on Ubuntu and you still insist in doing so. What's your point? Wasting time of people who want to be supportive to people who really have issues with Ubuntu or just driving people mad? THANK YOU SIR! So it did install in some way for 7.04/7.10 but the kernel you are using indicates that you are using 11.04, which is not even an LTS. Most of the packages are incompatible and 11.04 has just a few month of support ahead. There is no point in trying to do this. If you have no money for RHEL use CentOS. –  LiveWireBT May 8 '12 at 9:47
add comment

While it is possible to install RPMs, packages for the originally called Red Hat Package Manager, through use of alien in Debian based Linux distributions like Ubuntu it is mostly not recommended. Use a RPM based enterprise distribution like Red Hat Enterprise Linux (RHEL), Oracle Linux or the free CentOS. They are all mostly built from the source code of RHEL and should provide compatible if not equal package versions of the available software in equal numbered releases (RHEL 6.1 = CentOS 6.1). There are also distributions like Fedora, but they are not recommended for running enterprise software.

I'm not very familiar with RHEL but 'EL5' indicates that this package is for RHEL5. The current version of RHEL is RHEL6. RHEL5 is still supported but phased out. Especially in enterprise environments you should use the most recent software version that contains all security patches that the vendor of the software provides and you should always get the software directly from the vendor.

share|improve this answer
    
Thanks for your feedback. Yes I know Oracle EBS is certified on RHEL, OEL and SLE. But I am trying to install in Ubuntu. –  Sairam May 8 '12 at 9:26
1  
That will not work until you compile all the dependencies on your own. Realize that if a vendor, who has financial interests in supporting his own product, does not support a specific platform, than there is a good reason why. Install on CentOS 5 and stop wasting peoples time. –  LiveWireBT May 8 '12 at 10:05
add comment

I don't really understand your question. First of all, Ubuntu is based on Debian, so what you call "rpms" are actually deb-files in Debian, rpm is used in Red Hat among others as far as I know. You can convert rpm-files into deb-files with a program called Alien, but that is probably unnecessary as deb-files are almost always available.

As to the actual packages, could you supply any information on why you are unable to install them? Could you not install them simply by running

sudo apt-get install 

For the packages that you are missing?

If you supply some more information on how you're experiencing the error, it might be easier to help you.

share|improve this answer
    
Thank you for your inputs. I am not able to install required package (previous entry) using apt-get install. –  Sairam May 8 '12 at 7:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.