Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot use the wireless network from my Sony VAIO E series laptop. My OS is Ubuntu 12.04. Please help.

share|improve this question

closed as unclear what you're asking by Eliah Kagan, Whaaaaaat, KasiyA, Seth Oct 11 at 14:40

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Welcome to Ask Ubuntu! It might be useful to edit your question to include more information about your specific wireless hardware, as described in this answer. Thanks! –  Christopher Kyle Horton May 8 '12 at 21:58

2 Answers 2

I had the same problem. My wireless option was grayed out in network manager.

Solution: Blacklist mac80211 and voilà!

Ubuntu 12 and sony vaio e 14 series

share|improve this answer

This is not invented by me, but credited to answers from others in the web. Thanks to them.

Initial problem:

Bought new Sony Vaio E Series. Installing using CD, Ubuntu 12.04. During installation wireless worked. After reboot NO!. Can not enable wireless.

http://www.dkvermalinux.in/2012/05/ubuntu-1204-lts-wifi-problem-hardware.html?showComment=1337448079507#c2311451036067978243

I found there:

rfkill list all

rfkill unblock all


rfkill list all, works, and show: soft blocking in 'acer-wireless: Wireless LAN, soft blocked: yes'

rfkill unblock all does not manage to change. After another rfkill list all, same status remains.


Then I learned from rfkill list - How to unblock?. Thanks, Leckensteyn.

sudo modprobe -r acer_wmi

It works. Wireless Networks works 'normal' as it should be.

Thanks everybody.

Regards,

Toni Ridwan

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.