Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu on a fit-pc2 specifications and after upgrading from 10.04 to 12.04 I get a black screen at boot time (before displaying the grub menu) and the computer hangs with no disk activity.

I have managed to boot Ubuntu 12.04 on a live USB key but had to add the following boot options to do so:

  • console=tty1 or console=text
  • acpi=off
  • noapic
  • nomodeset

Using boot-repair, I have tried to add these options to /etc/default/grub (see this pastie log for instance) but I haven't been able to fix the black screen issue.

I have tried many other things such as the workarounds mentioned on the web for PSB-GFX_drivers without any success and also to uncomment GRUB_TERMINAL=console with the result of getting a

No video mode activated

error.

During these tests, I have managed to break /boot/grub/grub.cfg and could then hit grub in command line. This gave me the chance to check that I can boot without problem if I type:

grub> set root=(hd0,1)
grub> linux /vmlinuz root=/dev/sda1 ro acpi=off noapic nomodeset console=tty1
grub> initrd /initrd.img
grub> boot

How can I tell grub to use these options?

share|improve this question
    
I had the same problem. This helped me: askubuntu.com/questions/131125/… –  user61694 May 8 '12 at 14:27
    
Hmmm... there is no such file as /etc/grub in grub2 and this should probably read /etc/default/grub. If that's the case, I have tried this already and that doesn't work in my case. –  Eric van der Vlist May 9 '12 at 18:17
    
What I really don't understand is that if I replace the content of /boot/grub/grub.cfg by the grub commands shown above the machine boots perfectly well but when I add the same kernel options in /etc/default/grub they seem useless. –  Eric van der Vlist May 9 '12 at 18:21

4 Answers 4

I have tested this solution with my own fitpc2 and it works.

You need to select "Windows XP", not "Other OS" in the bios settings.

share|improve this answer

After editing /etc/default/grub did you run sudo update-grub?

It doesn't update until you do that.

share|improve this answer
    
Yes, the bootinfo that is attached is after running update-grub. –  Eric van der Vlist May 14 '12 at 12:02

You can check your kernel options by checking the output of dmesg. Look for a line that starts with [0.000000] Kernel command line: . It might not be right at the start, as an example mine is line 145 this boot.

share|improve this answer

My screen lost connection after BIOS had been loaded, I went into BIOS and saw that it was put to DOS and WinXP. I tried switching both to other but nothing worked. I then put it back to DOS and kept the other and it booted with graphics. It works!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.