Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My LG laptop (LGZ1 R200) has been having issues since 11.04. And a clean install of 12.04 was flaky, giving tonnes of disk errors before starting half the time --- with 11.04 and 11.10 it gave errors but always started so I never bothered trying to fix it...

However after backing up and doing a clean install of 12.04 it would not start half the time, froze during boot, never restarting etc... I tried several installs of 12.04 from several disks then defeated I reverted back to a clean install of 10.04 which works like a charm, and was then able to upgrade from 10.04 to 12.04 and it works, starts, not as quickly as 10.04, but faster than it did with 11.04 or 11.10 and with no disk errors on startup.

So I guess my question is, why will it upgrade, but not install directly, and is that a problem? Is it because 10.04 was pre-Unity? Is it possibly a driver issue? Is it just a question of disk compatibility?

share|improve this question
add comment

2 Answers 2

It is impossible to speculate with the sparse information you have given about the nature of the 'freeze during boot' .... if you tried booting in recovery mode, as I've no doubt you did, what were the error messages? It is possible that your hardware is in some way below the requirements of 12.04. Why don't you boot into the live-DVD and use the 'Try Ubuntu' option. If that works flawlessly then something went wrong during the installation process. Did you see any errors, and did you use the defaults or manually configure the partitioning as it installed?

share|improve this answer
    
Sorry it works like a charm from the try ubuntu option. I used the defaults and manually configured the partition. I figured that could have been the issue. Sorry I did not save the error messages, I was so used to seeing them. –  Menoitios May 9 '12 at 13:54
    
As for the hardware... I got it for free and I know that the above listed specs are wrong. It has a Intel Core 2 Duo T5750 with 2 gigs of ram and a 230 gb hard drive. And according to system details it has an Intel 965GM x86/MMX/SSE2 graphics card. I tried installing the ATI Radeon HD 2400 driver, because I thought it might be a mismatch, but it did not install. –  Menoitios May 9 '12 at 14:02
    
oh and I did try booting in recovery mode. It worked on and off. I installed 12.04 4 or 5 times from two different disks, trying different partitioning schemes and the default and restarted it multiple times each install. Finally I installed 10.04 and upgraded. –  Menoitios May 9 '12 at 14:05
    
One more note: I used one of the same install disks to install 12.04 on my Toshiba laptop. It worked perfectly. –  Menoitios May 9 '12 at 14:07
    
If it worked perfectly from the DVD, you should get it to work OK as an install. I'm not sure but I have an idea that the live-DVD migh start in the Unity 2D mode. Did you try stitching to 2D from the login screen as suggested by Adamthegeek, and did this help? I can't help thinking there could be a hardware fault in your box. I'm sure you will have run memtest86 but I wonder if you ran the SMART tests on the hard drive. The disk utility can do this for you. –  barrydrake May 9 '12 at 16:02
add comment

Sometimes upgrades have slightly different fs layouts and slightly different programs and minute differences from clean installs. But, in any way, looking at the specs of your laptop:

LG Z1 (XNote R200)

Specs Intel Core 2 Duo T7300 (2.0 GHz), 1 GB RAM, 160GB HDD, 12.1-inch screen (1280 x 800 pixels), ATI Radeon HD 2400, Bluetooth, WLAN,

That 1 gig of ram there looks very close to minimum for unity. Try running unity-2d or maybe xfce/gnome3 for a better experience. But, I dont know about the freaky filesystem issues. Maybe unity crashing on your machine is causing corruption???

share|improve this answer
    
Well the problem happens before unity starts. And the machine in question has 2 gigs of ram (don't remember if I put it in or it came that way ---- it was a second hand machine someone bought with vista installed, I got it for free because it had become so virus laden that they had gone out and bought another laptop and just wanted rid of it). –  Menoitios May 9 '12 at 13:51
    
BTW I know that the above listed specs are wrong. It has a Intel Core 2 Duo T5750 with 2 gigs of ram and a 230 gb hard drive. And according to system details it has an Intel 965GM x86/MMX/SSE2 graphics card. –  Menoitios May 9 '12 at 14:01
    
True that I got this info from an indian website –  Adamthegeek May 11 '12 at 0:18
    
Maybe specs are diff in india? –  Adamthegeek May 11 '12 at 0:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.