Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 12.04 printer share keeps asking for password and I can't authenticate from any machine. Why?? We've installed it in two machine (to act as printer servers) and we get the same problem.

It doesn't matter what we do, change or install. We can't figure out why the printer share asks for password even using all of the users that are registered in the server.

What is wrong with Precise? I want it to work without a password, but it is not even working WITH one!

I gave up! The samba version that comes with Precise is insufferable! I tried various settings that didn't work. I should've used Mint from the beginning.

[Edit] My printers config. Remembering that samba is 3.6.3 in ubuntu 12.04

load printers = yes
[printers]
comment = All Printers
browseable = yes
path = /var/spool/samba
printable = yes
guest ok = yes
readonly = yes
create mask = 0700

[print$]
comment = Printer Drivers
path = /var/lib/samba/printers
browseable = yes
readonly = yes
guest ok = yes
share|improve this question
add comment

4 Answers

up vote 1 down vote accepted

I have rarely had luck configuring a CIFS-reachable printer within Ubuntu. I've done it, but I don't do it every day: it's possible, with subtleties.

However, I've been able to share printers via http and https routes. The quick description of this method:

    [US] (= Ubuntu "Server")    example IP = 10.0.0.1
    [WC] (= Windows "Client")
  1. On [US], install a printer, ensuring that it is "Shared" via the GUI (e.g. the system-config-printer interface) or manipulation of /etc/cups/ files.

  2. On [WC], use a web browser and point to CUPS on [US].

    e.g. http://10.0.0.1:631/

    This should show you the web interface provided by CUPS. "CUPS is the standards-based, open source printing system ..." This also serves as a test to make sure that the machines can even talk, and that you don't have a more basic problem (e.g. firewall) to solve.

  3. The upper-right tab on this web page is a link to the Printers list.

  4. Right-click-and-copy the URL to the printer in question, and you can paste that into the Windows "Add Printer Wizard" interface for a network printer.

As asked, this should solve the authentication issue by bypassing Samba (CIFS). However, note that this method allows anyone on your local network to print to the shared printer, and it relies on a stable network IP address for [US].

It is also possible to restrict through authentication who can print, but that is for a different question.

share|improve this answer
    
Hi! Can I access it from windows machines? Using the \\server\printer_share? –  tenshimsm May 15 '12 at 0:06
    
I don't think so, as that syntax implies CIFS. However, Windows may have gotten smarter since 7, so try it and see. –  hunteke May 22 '12 at 20:31
    
Someone else probably solved that there. I don't work there neither my colleague. Only we were trying to solve it. Using via CUPS as suggested by hunteke it's a very much elegant solution. Nowadays I use that one. –  tenshimsm Feb 8 at 13:13
add comment

Seems like bug in Samba in Ubuntu 12.04...

https://bugs.launchpad.net/ubuntu/+source/samba/+bug/967410

share|improve this answer
add comment

If you still not get any solution. Try this.

Normally root password is disabled in ubuntu, Change the root password and try that.

"sudo passwd root" in terminal, set a new password for root. Give the same while prompts for authentication.

It worked for me.

Source: "Adding Printer" dialog asks for root password?

share|improve this answer
add comment

this worked for me. ensure that 'publish shared printers' option is enabled in your printer server and in your clients 'show printers shared by other system' option is also enabled. n/b this works best for linux server and linux clients

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.