Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This started to happen immediately after I had rebooted the first time after doing a system upgrade. It first starts with a dialogue that says "System program problem detected". Then when I try to hit 'report problem' not much happens. I am led through a dialogue that always ends up the problem cannot be solved.

I am aware this is not a lot of information, however I'm not sure which information I need to publish and how should I obtain it to debug this problem.

Here's a screenshot! enter image description here

share|improve this question

Open a terminal (Ctrl+Alt+T) and type:

sudo rm /var/crash/*

Then hit Enter.

This will remove any old crashes, that might still be reported (in error). After a reboot/re-starting, any further pop-ups still need to be investigated.

share|improve this answer
Genius! Concise yet precise. This also happens every time you switch between kernels in the same OS. – Ébe Isaac Apr 22 at 3:53
wow, actually that is the best awnser i saw until now for this issue, it works and as a bonus keeps apport enabled, also now i see the real issues i have – spider623 Jun 26 at 23:27

Disabling error-reporting is not a desirable solution!

Ubuntu has an error reporting system called apport which tries to catch all program crashes in the background and report them to help the developers.

It seems that after a dist-upgrade there are stuck some reports that are tried to be resubmitted somehow, but disabling apport is not a desirable solution.

Remove old crash-reports

Open a terminal and remove all old crash-reports that might exist in the crash-report directory:

sudo rm /var/crash/*

After a reboot the popups are gone.

If you don't want to reboot, you can close all open popups with:

killall system-crash-notification

(Any further new pop-ups still should be investigated. If you want to see the details,
look in /var/crash/ for any new reports)

share|improve this answer
If the developers don't want people to disable error reporting, they should probably make it work right. This seems to be a long-existing and very visible bug. Still, this is a good answer. – nobar Nov 16 '14 at 22:57
Ah, I knew the logs that triggered this thing had to be somewhere, just needed to know which folder :) Thanks! – Aditya M P Dec 12 '14 at 10:07
Upvoting because of how many people don't understand first line of your post. – Błażej Michalik Apr 3 at 2:38

Here's how to disable Apport, the system that reports errors to Canonical:

Open your terminal and type:

gksudo gedit /etc/default/apport

And hit Enter.

Change enabled=1 to enabled=0, then save and exit.

To solve this problem, you can watch this YouTube video.

See also: How do I enable or disable Apport?

share|improve this answer

I have had the same problem when upgrading from 12.04 to a higher version. As it turns out, Ubuntu has an error reporting system called "apport", which was deactivated in stabled releases of Ubuntu until 12.04 and is reactivated now.

Manuel Jose has made an excellent quick-guide how to turn off the error reporting in apport

share|improve this answer

If you would like to turn off the config setting without using a GUI:

sudo crudini --set /etc/default/apport '' enabled 0
share|improve this answer

protected by Community Jan 23 '13 at 16:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.