Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04 and found my wireless card is not detected by OS. I tired to detect it by network manager but still it is not get

output of the required command:

toor@Linux:~$ sudo lshw -class network
  *-network               
       description: Ethernet interface
       product: AR8131 Gigabit Ethernet
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: c0
       serial: f0:de:f1:9e:22:4d
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full firmware=N/A ip=124.123.227.84 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:44 memory:f2400000-f243ffff ioport:2000(size=128)
  *-network UNCLAIMED
       description: Network controller
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:04:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f2500000-f250ffff

and 
toor@Linux:~$ rfkill list all
0: ideapad_wlan: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: ideapad_bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no

Please let me know what more info is required to resolve it.

share|improve this question
add comment

4 Answers

Your problem is two-fold and you'll have to handle both errors.

  • *-network UNCLAIMED means no kernel module (driver) is taking care of this piece of hardware.

    For your device, I'd recommend first to see if there are drivers available using the regular method: How do I install extra drivers?

    In case that doesn't list any drivers for your device, try installing backported drivers from newer Linux kernels. Ubuntu has packages available for these so-called compat-wireless set of drivers. See my answer in another related question on how to do this.

  • ideapad_wlan: Wireless LAN, Soft blocked: yes means that your radio kill switch is activated. This prevents all communication and is useful in case you intend to do so (e.g. when requested in an airplane). To enable your radio, disable this killswitch by issuing

    sudo rfkill unblock all
    

    to enable both WiFi and Bluetooth in your case.

See My WiFi adapter is not working at all. Where to start troubleshooting? for a more general, complete how-to.

share|improve this answer
add comment

you can get your wireless drivers by looking at additional driver details and downloading them respectively. Since you have not provided me any details of your wireless adapters and PC spes, I could not help you more on this right now.

share|improve this answer
add comment

I have a laptop with the same wireless card and it worked out of the box.

However, I realised that if, while on windows I disable the wifi, I'm not able to enable it on Ubuntu. Booting Windows, enabling wifi and rebooting solves the issue.

If you are not dual-booting, try entering the Bios setup, find the wifi card and enable it if necessary.

share|improve this answer
add comment

Why don't you try to install the drivers for your wireless card?

  1. Download this drivers: compat-wireless-3.6.8-1.tar.bz2
  2. Install the drivers:

    tar -xf /path/to/compat-wireless-3.6.8-1.tar.bz2
    cd /path/to/compat-wireless-3.6.8-1
    ./scripts/driver-select ath9k
    make
    sudo make install
    
  3. Reboot your computer.

If this doesn't work let me know.

share|improve this answer
    
Wait a moment. You don't have to compile from source. There's a package for this. See my answer in another related question. –  gertvdijk Jan 2 '13 at 3:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.