Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to open Software Center, the icon blinks, but nothing happens. When I type sudo software-center in my terminal I get:

2012-05-07 12:57:18,385 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 15 21
Traceback (most recent call last):
  File "/usr/bin/software-center", line 151, in <module>
    app = SoftwareCenterAppGtk3(datadir, xapian_base_path, options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 213, in __init__
    self.cache.open()
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/aptcache.py", line 209, in open
    self._cache = apt.Cache(GtkMainIterationProgress())
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 93, in __init__
    self.open(progress)
  File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 140, in open
    self._list.read_main_list()
SystemError: E:Malformed line 54 in source list /etc/apt/sources.list (dist parse)

I have Ubuntu 11.10. I am new to Linux. Appreciate your help!!!

share|improve this question
    
Does this problem happen even after restarting? –  Mohd Arafat Hossain May 7 '12 at 18:12
    
post your /etc/apt/sources.list –  Jacob Johan Edwards May 7 '12 at 18:42
add comment

1 Answer

This is your problem:

SystemError: E:Malformed line 54 in source list /etc/apt/sources.list (dist parse)

Do a

gksu gedit  /etc/apt/sources.list 

from command line and locate line 54 and see if you can fix it. If unsure what is wrong add it to your question and we'll have a look at it.

share|improve this answer
    
When I typed in gksu gedit /etc/apt/sources.list, I got: (gksu:2374): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", (gksu:2374): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", (gksu:2374): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", (gksu:2374): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap", Thanks to all for your suggestions!! Elaine Also want to mention that I can't install Skype or Google Earth--suppose it's all due to the same problem. Thanks again!! –  Elaine May 7 '12 at 21:58
    
Thank you, @Rinzwind. Don't know how to fix the error on line 54. –  Elaine May 8 '12 at 0:00
1  
Those 1st warnings we all have and are harmless. It should just open gedit with some lines though!! Otherwise do, from commandline, a more /etc/apt/sources.list and copy the outpot into your question. –  Rinzwind May 8 '12 at 6:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.