Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run Ubuntu 10.10 64-bit desktop edition and I have Panasonic networked printer KX - MX2000 printer.

There are no 64 bit drivers available from Panasonic for Ubuntu/debian. They only have 32 bit drivers for RHEL :( So - there is no way I can print from my computer to that networked printer directly.

So - my idea was to install printer drivers onto Windows XP VirtualBox guest and just printer from virtual machine.

I've installed XP drivers onto guest, VirtualBox network adapter set to Bridged, I can see printer in the browser from guest, I can ping printer from guest but when I try to print nothing happens.

What am I doing wrong. IS there something else I have to configure?

UPDATE:

Panasonic Red Hat drivers: http://panasonic.net/pcc/support/fax/common/table/linuxdriver.html

TO INSTALL THEM ON UBUNTU

sudo alien --scripts -k libjbig-1.0.0-1.i386.rpm libtetra-1.0.0-2.i386.rpm rastertogdi-1.0.1-9.i386.rpm

sudo dpkg -i libjbig_1.0.0-1_i386.deb libtetra_1.0.0-2_i386.deb rastertogdi_1.0.1-9_i386.deb

sudo service cups restart

now - there will be some errors during execution which shouldn't affect anything.

BUT THE PROBLEM IS

I cannot get it to work on Ubuntu Maverick 10.10 64 bits (or any other 64 bits distro for that reason. Only tried on Ubuntu 10.10 64 though.). Any sugguestions guys? :) Thanks

share|improve this question
    
hmmmm.... nevr mind..... –  Stann Nov 15 '10 at 8:08
    
got it figured out...I was doing everything right. Just had to reinstall drivers in the guest Xp machine... go figure.....So glad I don't use windows anymore :) –  Stann Nov 15 '10 at 8:09
    
Please consider deleting your question or rephrasing it so we can answer with something useful for others. Can you link to where you got the linux 32bit drivers? –  Martin Owens -doctormo- Nov 15 '10 at 11:56
    
sometimes alien can move something from rpm to deb...just a thought as something useful getting into the question –  hbdgaf Nov 15 '10 at 15:50
    
addedd manufacturer drivers link and conversion instructions for dwbian/ubuntu. IS there any way to install them on 64 bit Ubuntu Maverick though? Anyone? :) –  Stann Nov 15 '10 at 19:57

1 Answer 1

up vote 1 down vote accepted

I don't think it's possible to get the 32bit driver installed on 64bit currently. But if you know you have a 32bit requirement it might be worth getting 32bit desktop instead.

As for virtual box, there is no reason I can think of why it wouldn't work. Try reinstalling the windows drivers and making sure the network is good.

share|improve this answer
    
Thanks. I've got it to work through Virtualbox which will do for now. Since I have 8 gb of Ram it seems like such a waste to use 32 bit version :) so I hope Panasonic will come out with 64 bit driver some time in the future. –  Stann Nov 15 '10 at 23:34
    
You can still use 8gb of RAM on 32bit, just use the intel memory page extensions. –  Martin Owens -doctormo- Nov 16 '10 at 0:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.