Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Laptop runs perfectly cool on battery but immediately I remove the battery the laptop goes all guns blazing and begins to overheat. How can I instruct the Kernel to maintain the power saving features (used on battery) when using AC?

HP PAVILION DV6700 Intel Core 2 Duo 2.0Ghz 4gb RAM Intel Mobile Chipset 965GM (x3100)

Jupiter is already installed and set to Power savings. Problem is once the kernel detects it running on battery it sort of ignores Jupiter and other power saving features. It seems these fears only kick in when running on battery.

Jupiter does keep power savings on but the laptop starts to overheat ONLY on AC. I just want it to run like how it does when running on battery.

share|improve this question

marked as duplicate by Raja, Jorge Castro, Uri Herrera, Eric Carvalho, Kevin Bowen May 20 '13 at 3:25

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
hey you posted this 2 times? askubuntu.com/questions/69355/… does the accepted vote work now? –  Rinzwind May 7 '12 at 16:53
    
It did help but since it was a kernel issue, 12.04 fixed it (at least on battery). This question is quite different from the old one as the issue is fixed on battery. Just need same to be replicated on AC –  Mysterio May 7 '12 at 17:04
1  
You might try enabling laptop-mode (using laptop-mode-tools). You can force it to run even on AC. –  Chan-Ho Suh May 9 '12 at 22:06
    
@Chan-HoSuh laptop_mode is installed and already enabled –  Mysterio May 11 '12 at 9:24
    
...you mean enabled on AC? You have to force it to do that. –  Chan-Ho Suh May 11 '12 at 9:31

1 Answer 1

up vote 1 down vote accepted
+50

Edit /etc/laptop-mode/laptop-mode.conf and change

ENABLE_LAPTOP_MODE_ON_AC=0

to

ENABLE_LAPTOP_MODE_ON_AC=1

Now restart laptop-mode with:

sudo /etc/init.d/laptop-mode restart

Check that it's active on AC with for example:

$ sudo laptop_mode start

which gives me:

Laptop mode 
enabled, 
active [unchanged]
share|improve this answer
    
Thanks I can only hope it runs same on AC –  Mysterio May 13 '12 at 21:53
    
can you also help me out as the temperature of my hard drive surges on AC but runs so cool on battery –  Mysterio May 24 '12 at 10:22

Not the answer you're looking for? Browse other questions tagged or ask your own question.