Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed ubuntu 12.04 and installed okular but with normal user i can't run okular and give me an error that "Unable to find the Okular component." but with root user i can run it without any errors. what should i do?

I've tried to purge and install okular itself, but this has not worked.

share|improve this question
    
How did you install Okular? With Ubuntu Software Center or sudo apt-get install or ...? –  Jakob May 8 '12 at 7:41
add comment

1 Answer

You should never run GUI programs as root unless explicitly noted. Changes are that files in your home directory now have wrong ownership. Find those files and restore the ownership:

  1. Open a terminal
  2. (optional, but recommended for verifying) Find all files that are not owned by you:

    sudo find ~ ! -user $(id -u) -ls

  3. Find all files and restore the ownership to yours:

    sudo find ~ ! -user $(id -u) -exec chown $(id -u) {} \; -ls

If unsure, you can leave a comment here with a link to http://paste.ubuntu.com/ containing the output of step 2.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.