Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop is Acer Aspire 4741G:

  • CPU: Intel Core i5 460M(2,53GHz)
  • 6 Gb RAM (Kingston DDR3 2gb+4gb)
  • 320 Gb HDD
  • NVIDIA Ge Force GT 420M (1 Gb)

Tried Ubuntu 10.04, 10.10, 11.10, 12.04, here are the results:

  • 10.04 - no overheat, usual T=50-55C - only troubles in installing Video drivers for GT420M

  • 10.10 - no overheat, usual T=50-55C - only troubles in installing Video drivers for GT420M

  • 11.10 - proprietary drivers for video are just fine, but overheats(T=60-70 C)

  • 12.04 - proprietary drivers for video are just fine, but overheats(T=60-70 C)

for 11.* & 12.04 - when just installed - temperature is almost normal(idle t=55-60, when watching video's t=60-65 C).

After about 1-2 days(installed: Chromium browser, Mozilla Thunderbird, PCSX-R, qBittorrent, Skype, SMPlayer.) the temperature went up till: idle t=65-70C, working t=70-80C(Note-the temperature goes up after 1-5 minutes after booting computer, and i don't start such programs, as qbittorrent, Skype, SMPlayer, PCSX-r etc).

Tried to re-install video drivers, no luck, temperatures are all the same: idle t=65-70C, working t=70-80C(also in idle found, that some of the screenlets are lagging, & videos have mistiming glitches, which could be solved only by restarting the application). P.S.: Needless to say, that laptop is always in my hands,or on table, & there is always 1-2 inches gap between bottom of laptop, & any surfaces.

P.P.S.: I have Windows 7 dual boot on this laptop & temperatures in Windows are MUCH different(idle= 45-55 C, working= 60-65C)

share|improve this question
add comment

2 Answers

I searched with your laptop model in Internet. Couldn't find a product page in acer. But the driver page points that this model has nvidia optimus enabled. If your system has duel graphics card and optimus enabled you need to turn off the discrete graphics card. Otherwise both are enabled and lead to high temperature.

Instruction for installing Bumblebee to turn off discrete GPU and enable only when required

  1. Type the following in terminal,

    sudo add-apt-repository ppa:bumblebee/stable then sudo apt-get update

If you are on Ubuntu 11.04 or older and want newer drivers (recommended) than the ones available in the official repos, run:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

  1. To install Bumblebee using the proprietary nvidia driver:

    sudo apt-get install bumblebee bumblebee-nvidia

  2. Run following

    sudo usermod -a -G bumblebee $USER

  3. Reboot.


If you just want to disable nvidia card, no need to learn followings

Usage Instruction :

To run a program with nvidia card, use optirun command prefixed in terminal. Like to run glxspheres with nvidia card type

optirun glxspheres

To run firefox type : optirun firefox &

Note: If you intend to run 32-bit programs like Wine and using Ubuntu 11.10 Oneiric or later, install 32-bit libraries with: sudo apt-get install virtualgl-libs:i386 libgl1-mesa-glx:i386 libc6:i386

Linked Questions:

How well will Nvidia Optimus cards be supported in 12.04?

How well do laptops with Nvidia Optimus work?

Can't use nvidia card/driver on optimus notebook

share|improve this answer
add comment

May be this isnt the right solution for you, but it happened to me similarly. Although, the problem due to my cooling system problem, it was too dirty. I vacuum cleaned the ventilation and the heating problem was gone :O surprisingly. You might wanna tried that first!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.