Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i have installed nagios and i want to install nrpe. While installing NRPE, when i execute (/home/abc/nrpe/configure)

./configure

it stops after reaching the following line

...

checking for type of socket size... size_t
checking for SSL headers... SSL headers found in /usr
checking for SSL libraries... configure: error: Cannot find ssl libraries

I have installed libssl-dev and openssl package as i found them as a solution for this error.

I tried the following option also

./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib

But the error remains.

What can be the possible solution for this ? I am using ubuntu 12.04 as my operating system. Thanks in advance.

share|improve this question
up vote 20 down vote accepted

this worked for me:

./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/x86_64-linux-gnu

I found the dir through:

apt-file search libssl | grep libssl-dev
share|improve this answer
1  
Thanks for reply. I end up with the installation of the older version of nrpe and that worked for me. – ankurtr May 11 '12 at 19:54
    
This worked! Thanks. For future reference, in what docs did you find those configure --with options? – WAF Feb 18 '15 at 12:56
    
I had to combine this with another answer, and install libssl-dev first. sudo apt-get install libssl-dev – IBam Feb 17 at 11:02

Use the following command to fix it:

yum install openssl-devel

share|improve this answer
1  
Yum is not used in ubuntu. Should be sudo apt-get install openssl-devel – rechengehirn Dec 4 '13 at 9:07
    
thanks for the centos advice!! – Dobler Mar 24 '15 at 20:16

I had similar issues on a Raspberry PI, after I'd installed the libssl-dev package

sudo apt-get install libssl-dev

but managed to find the ssl lib for the configure command with this:

# dpkg -L libssl-dev

.
.
.
/usr/lib/arm-linux-gnueabihf
/usr/lib/arm-linux-gnueabihf/libssl.a
/usr/lib/arm-linux-gnueabihf/pkgconfig
/usr/lib/arm-linux-gnueabihf/pkgconfig/libcrypto.pc
/usr/lib/arm-linux-gnueabihf/pkgconfig/libssl.pc
/usr/lib/arm-linux-gnueabihf/pkgconfig/openssl.pc
/usr/lib/arm-linux-gnueabihf/libcrypto.a
/usr/lib/arm-linux-gnueabihf/libssl.so
/usr/lib/arm-linux-gnueabihf/libcrypto.so

# ./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/arm-linux-gnueabihf
share|improve this answer

With Ubuntu Server, try this:

sudo apt-get install libssl-dev
share|improve this answer

protected by Community Apr 25 '14 at 2:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.