Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i have installed nagios and i want to install nrpe. While installing NRPE, when i execute (/home/abc/nrpe/configure)

./configure

it stops after reaching the following line

...

checking for type of socket size... size_t
checking for SSL headers... SSL headers found in /usr
checking for SSL libraries... configure: error: Cannot find ssl libraries

I have installed libssl-dev and openssl package as i found them as a solution for this error.

I tried the following option also

./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib

But the error remains.

What can be the possible solution for this ? I am using ubuntu 12.04 as my operating system. Thanks in advance.

share|improve this question

4 Answers 4

this worked for me:

./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/x86_64-linux-gnu

I found the dir through:

apt-file search libssl | grep libssl-dev
share|improve this answer
1  
Thanks for reply. I end up with the installation of the older version of nrpe and that worked for me. –  ankur.trapasiya May 11 '12 at 19:54

I had similar issues on a Raspberry PI, after I'd installed the libssl-dev package

sudo apt-get install libssl-dev

but managed to find the ssl lib for the configure command with this:

# dpkg -L libssl-dev

.
.
.
/usr/lib/arm-linux-gnueabihf
/usr/lib/arm-linux-gnueabihf/libssl.a
/usr/lib/arm-linux-gnueabihf/pkgconfig
/usr/lib/arm-linux-gnueabihf/pkgconfig/libcrypto.pc
/usr/lib/arm-linux-gnueabihf/pkgconfig/libssl.pc
/usr/lib/arm-linux-gnueabihf/pkgconfig/openssl.pc
/usr/lib/arm-linux-gnueabihf/libcrypto.a
/usr/lib/arm-linux-gnueabihf/libssl.so
/usr/lib/arm-linux-gnueabihf/libcrypto.so

# ./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/arm-linux-gnueabihf
share|improve this answer

With Ubuntu Server, try this:

sudo apt-get install libssl-dev
share|improve this answer

Use the following command to fix it:

yum install openssl-devel

share|improve this answer
1  
Yum is not used in ubuntu. Should be sudo apt-get install openssl-devel –  rechengehirn Dec 4 '13 at 9:07

protected by Community Apr 25 at 2:20

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.