Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hey I managed with the help of a friend to get 10.04 onto a 2TB WD USB drive for dual boot but it doesn't want to work on my Vista loaded laptop. Is there a fix? i don't have the choice of erasing Vista. The drive works on another Ubuntu laptop. I have yet to try it on my dad's XP machine.

share|improve this question

closed as too localized by Luis Mar 14 '13 at 16:31

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

4 Answers 4

With some laptops, plug the USB drive in then turn on the power. Press F2 or Delete to enter the PC BIOS settings.

The setting you want is usually under the BOOT section (use left/right arrow keys to change sections) and check the boot device order, make sure USB is before hard drive.

If you are unsure about changing anything, have a look and write down what options you see, exit without saving and let us know what options there is.

share|improve this answer

If you have grub installed on the USB drive, you can boot unsupported operating systems (such as windows) by chain loading. Find your way to the grub command prompt and enter these commands:

grub> rootnoverify (hd0,0)
grub> makeactive
grub> chainloader +1
share|improve this answer

First,is the usb drive bootable, and did you select it at boot time from the BIOS boot screen ? Have you set the BIOS to put the USB drive first, or do you select from a menu each time you boot?

If you enter your BIOS, and move USB to the top of the boot order, it should select the USB Hard drive automatically at boot up.

share|improve this answer

The Computer(s) you are tying to run Ubuntu on may not support booting from USB. If this is the case either update your BIOS or get a new Computer. If it is compatible then check the boot menu which varies from PC so look for the key Combination for "Boot Menu" or "Boot Select" at startup. If I works you should be able to see the 2TB drive.

share|improve this answer