Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

lenovo i7, 64 bit, win7, 11.10 on sda10 with home on sda8+swap on sda9. root 12.04 on sda12 with /usr on sda11 complete new. There was kubuntu before with grub, the grub on sda10 didn´t work, but all entries have been fine.
Install of 12.04 ok, but after reboot: file not found, grub rescue promt which even does not accept exit!
After set prefix, set root, insmod comes: invalid arch independent ELF magic. This seems to be the real reason.
Win7 repair finds nothing, parted magic cannot install lilo instead, the grub rescue-CD updates grub on sda10-same error,,,but fails to update grub on sda12!
I tried to start via parted magic but don´t know the correct command. I am happy to have not updated, because there seems to be many problems with 12.04! If i could boot with grub on sda10 (old system) again is enough. But how to do? Marek

share|improve this question
    
I tried grub-install, on both sda10 and sda12 same error: /usr/sbin/grub-probe: error: cannot stat 'aufs'. The first' in front of aufs shows really from topleft to downright. This elf is under /usr on sda11 on my machine, magic text only under /etc marek –  Marek May 7 '12 at 15:47

1 Answer 1

" after reboot: file not found, grub rescue promt" This means that grub's core.img, embedded in the post-mbr gap, is looking for /boot/grub/ on the wrong partition.

"After set prefix, set root, insmod comes: invalid arch independent ELF magic." This means that the /boot/grub/ that you pointed grub to is for a different version of grub than the version of grub that the embedded core.img came from.

Those two things together strongly suggest that the core.img embedded in the post-mbr gap is from a previous Ubuntu install, not from your most recent Ubuntu 12.04 installation. To fix this you need to run grub-install, which when run from a LiveCD either requires a chroot or the --boot-directory= argument, and make sure that you tell grub-install to install to the MBR (not to a partitition) of the drive which your BIOS is booting from (don't assume that you know which one this is, it's commonly not the one people think is being booted from when they have multiple hard drives). If you have multiple drives, it's probably best to install grub's boot sector to all of them.

To install grub from a LiveCD, follow this guide: https://help.ubuntu.com/community/Grub2#ChRoot

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.