Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install the Numenta Platform in Ubuntu12.4.

It created by python 2.5 and for Ubuntu 9.4.

You can see the installing step and requerment in the below link The Numenta installing help

But in Ubuntu 12.4 we have the python 2.7 and upper so when I tried to play the Numenta Platform faced to this error:

ImportError: libpython2.5.so.1.0: cannot open shared object file: No such file or directory

After I inserted this commands in .bashrc file to change the python path to my Platform folder:

NTA=$HOME/nta 
export PATH=$NTA/bin:$PATH 
export PYTHONPATH=$NTA/lib/python2.7/site-packages:$PYTHONPATH

But faced to the recent error again. It seems that the Platform is using from python2.5 yet. I don't know how can I run The Numenta Platform now.

Thanks for attention.

share|improve this question
add comment

1 Answer

You could try installing Python2.5 via the DeadSnakes repository:

sudo add-apt-repository ppa:fkrull/deadsnakes
sudo apt-get update
sudo apt-get install python2.5
share|improve this answer
    
Is any way that solve this problem without python 2.5? –  Amin May 8 '12 at 9:44
    
I installed python2.5 but faced to that error again.What I have to do now? –  Amin Jul 22 '12 at 6:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.