Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have windows for an editor, a browser, a web application, and a development tool for that browser open. Unity groups them as two applications: Chrome and Eclipse.

Alt-Tab switches application group, Alt-` switches windows in the same group. But, if my current window and previous window are from the same application group (Chrome), Alt-Tab switches to the previous window, not to Eclipse.

How can I configure Alt-Tab to always switch between application groups, not windows of the same app?

share|improve this question
    
Here is a related bug entry: bugs.launchpad.net/ubuntu/+source/unity/+bug/998285 . Please subscribe to it and say that you're affected. –  gkcn May 2 '13 at 13:14
3  
This is not off topic (maybe a duplicate, but I haven't searched). The answer with 10+ upvotes here is the correct one, though. –  dobey May 2 '13 at 15:49

3 Answers 3

Here is how to solve this:

  1. Open CompizConfig Settings Manager
  2. Go to the Unity Plugin settings and deactivate (uncheck enbabled) for the Alt+Tab and Alt+Tab+Shift shortcuts (or even all the other "switcher" related shortcuts.
  3. Then go to the CompizConfig main menu and to the "Window Management" section and enable one of the "Switchers", for example "Shift Switcher" or "Static Application Switcher".

All of these Switchers expose the old behaviour.


If you don't mind using the mouse instead of keyboard-shortcuts - one more note:

The Unity Dash (the menu that comes up when you go to the left side of the screen) also works like an "old" taskbar. Clicking on an active app's icon brings that app's window to front. If an app icon indicates two or more windows of one app open, double-clicking opens a multiple-window grid that I think is more convenient than the multi-window "sub selector" that comes up through Alt+Tab for that same app group.


Update:

Actually now, I've come to accept the "grouping switcher" but with one novel way of using it (novel, at least for me):

I've found out that once you're working in one window from a group, you can switch between windows from this group by using ALT+^ (instead of ALT+TAB), for example switching between multiple instances of leafpad. And switching between windows from one group is what I usually do most, or wanted to do with ALT+TAB before. So this as a tip for everyone not knowing this very handy short-cut.

share|improve this answer
1  
It would be nice to have a solution which doesn't require installing the whole ccsm. It must be possible to change this behaviour with a dconf command or by editing some config file, no? –  mivk Nov 17 '12 at 12:10
    
This no longer works in 13.10 - there is no static application switcher. Does anyone know how to get that installed? –  sunew May 20 at 11:54
    
EDIT: compiz-plugins. But the old switchers switch between all windows, not just applications, so basically this is not the answer to the original question. (besides, they seem a little unstable: not all options take effekt etc. etc.) –  sunew May 20 at 12:05
    
Window Management seems not present in 14.04 –  Pierre de LESPINAY Jul 25 at 9:46

Here is a workaround. Install ccsm, then deselect Desktop > Ubuntu Unity Plugin > Switcher > Automatically grid windows on timer in switcher. You might need to run "$ unity --replace" to get the settings to stick.

Having this setting on does the following. When holding onto alt-tab, if you wait with your selection over an application icon with multiple windows open, after a short time the window thumbnails are exposed. If this setting is off, then alt-tab only shows the application icon.

(It's a bit odd that changing this setting should have this side-effect, as it's not directly related, so it might be a bug? Perhaps it's a feature, but I've filed a bug in launchpad anyway.)

share|improve this answer

By default the switcher is configured to switch applications like you mentioned. If you wish to change the behavior so that Alt+Tab will switch windows you can try the following:

Launch CompizConfig Settings Manager and choose the "Ubuntu Unity Plugin".
Currently the 'Switcher' tab probably looks like this:

enter image description here

Try moving the configuration of assigned keys from the first two rows to the marked last two.

share|improve this answer
1  
Hi! thanks for your answer, I've tried it, but it makes the opposite I'd liked to achieve. Now if I'm in a 'group' (chrome windows) and hit ALT+TAB it switches between the group's windows, and I cannot access eclipse (: I think I'd need a hotkey that does both 'start switcher' and 'go right in the switcher'. Do you think I can get that funcionality shomehow? –  Szabó B. Gábor May 14 '12 at 6:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.