Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Symptoms are high temperature when high usage of CPU, with reboot when more than 100°C (information extract from ACPITZ/1 entry). I found a bug entry in launchpad about wrong fan speed but even if I force the fan to max (see the bug description of the launchpad entry) the computer is still rebooting after one minute of high CPU usage.

But I'm starting to suspect several bugs in my case. My battery has a lifetime of 2 to 3 hours, half of what I had before ubuntu 11.10 (~5 hours). So it maybe related to ASPM bug, but even with recent updates of the kernel I have still the problem. I've tried multiple kernel startup switchs fixup found with ubuntu 11.10 but nothing really changed. Abot ASPM, dmesg returns:

$ dmesg | grep ASPM
[    0.160288] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it

Maybe I need to try again with 12.04 ?

Two last things: - I cannot open my computer to remove possible dust (computer owned by my company, guaranty yada yada...) - I saw somewhere possible GPU overheating (cannot found the link), anyone has such experience ?

Any hint, clue or proposal welcomes...

update 1

I've also run 'powertop' and saw several other things:

First, Turbo mode of the processor is always running 25% of the time:

 Package             | CPU 0
 Turbo Mode  24.4%   | Turbo Mode  21.7%
 2.81 Ghz     1.8%   | 2.81 Ghz     1.6%
 2.14 Ghz     0.9%   | 2.14 Ghz     0.9%
 1.60 Ghz     3.3%   | 1.60 Ghz     3.3%
  800 Mhz    57.5%   |  800 Mhz    55.2%
 Idle        12.1%   | Idle        17.4%

                     |            CPU 1
                     | Turbo Mode  24.1%
                     | 2.81 Ghz     1.8%
                     | 2.14 Ghz     0.9%
                     | 1.60 Ghz     3.2%
                     |  800 Mhz    54.5%
                     | Idle        15.5%

Second, Tunables tab prints a lot of devices with important runtime (no economy energy mode ?):

   Bad           Enable SATA link power management for /dev/sda
   Bad           NMI watchdog should be turned off
   Bad           Power Aware CPU scheduler
   Bad           VM writeback timeout
   Bad           Enable Audio codec power management
   Bad           Autosuspend for USB device Fingerprint Sensor [4-1]
   Bad           Autosuspend for USB device USB Receiver (Logitech)
   Bad           Autosuspend for USB device Android Phone (HTC)
   Bad           Runtime PM for PCI Device Intel Corporation Mobile 4 Series Chipset Memory Controller Hub
   Bad           Runtime PM for PCI Device Ricoh Co Ltd R5C832 IEEE 1394 Controller
   Bad           Runtime PM for PCI Device Intel Corporation Mobile 4 Series Chipset MEI Controller
   Bad           Runtime PM for PCI Device Intel Corporation 82567LF Gigabit Network Connection
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) HD Audio Controller
   Bad           Runtime PM for PCI Device Ricoh Co Ltd xD-Picture Card Controller
   Bad           Runtime PM for PCI Device Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter
   Bad           Runtime PM for PCI Device Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
   Bad           Runtime PM for PCI Device Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
   Bad           Runtime PM for PCI Device Intel Corporation Ultimate N WiFi Link 5300
   Bad           Runtime PM for PCI Device Ricoh Co Ltd RL5c476 II
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) PCI Express Port 4
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) PCI Express Port 5
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) PCI Express Port 2
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) PCI Express Port 3
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3
   Bad           Runtime PM for PCI Device Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode]
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5
   Bad           Runtime PM for PCI Device Intel Corporation 82801I (ICH9 Family) PCI Express Port 1

Third, About "Power Aware CPU scheduler", changing cpu policy to powersave does not solve the problem.

update 2

Using switch 'acpi_osi=Linux' (as described here) does not fix the problem.

update 3

Seems this is not a problem with ASPM, as my computer does not seem to support it. If I had pcie_aspm=force to kernel, I've the following output:

$ dmesg | grep ASPM
[    0.000000] PCIe ASPM is forcibly enabled
[    0.197865] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
share|improve this question
    
This is bug #751689 "ThinkPads overheat due to slow fans when on 'auto'", as far as I can tell from the information provided. –  gertvdijk Jan 16 '13 at 12:50
add comment

closed as off topic by gertvdijk, hhlp, qbi, Thomas W., Jorge Castro Jan 16 '13 at 21:46

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

6 Answers

Well I have a problem about overheating too on my Lenovo T500. When I was using 10.04 LTS the temperature was around 60C even when watching HD movies etc... Now with 12.04 LTS my the temp is around 70+. And get easy over 80C when starting to use the computer. I did install thinkfan and configure it: etc/thinkfan.conf

(0, 0, 55) (1, 54, 57) (2, 56, 60) (3, 57, 63) (4, 58, 65) (5, 60, 66) (7, 70, 80) (127, 75, 32767)

It's really 12.04 LTS more heavy? That much to use that much more of CPU. Or I'm missing something? :)

p.s. It is possible that there is a bug for showing the temperature and actual temperature is same? Or is this just my humble wish :).

share|improve this answer
    
I really believe this is a deeper bug which deal with ACPI support in Thinkpad –  Kartoch Jul 11 '12 at 19:35
add comment

Recently had the same problem on a T400. My problem turned out to be related to the OS switchable graphics adapters. Try this:

~$ lspci | grep VGA

If the return includes more than one graphics adapter then you need to disable the integrated graphics adapter in the BIOS.

In my t400 BIOS Setup it should be:
--->Config----->Displays----->
--Default Display Device = PCI Express
--Boot Display Device = Thinkpad LCD
--Graphics Device = Discreet Graphics
--OS Detection for Switchable Graphics = Disabled

If your t500 does indeed have the switchable graphics adapters that includes a discreet AMD/ATI adapter, then you also need to install the fglrx driver.

share|improve this answer
    
Thank you but still the same problem, whatever is my choice about graphic card. –  Kartoch Jul 11 '12 at 19:36
add comment

I have a W500 and just put 12.04 on. I did enable the ATI card. I am fairly certain the fan will not go to the fastest speed (7). I cannot get manual options or things like thinkfan to drive it. I loved tpfan-admin, but something in python changed per this bug.

In the meantime, I was able to force using:

echo level 7 | sudo tee /proc/acpi/ibm/fan

(Found via http://www.thinkwiki.org/wiki/How_to_control_fan_speed.)

I swear yesterday I couldn't get anything out of /proc/acpi/ibm.

Something changed with the reboot today?!

share|improve this answer
    
Level 7 wasn't enough for dual-monitor using the discrete graphics, ATI in my case with open src drivers. I was able to use this command to get it to 4900rpm echo level full-speed | superuser tee /proc/acpi/ibm/fan where superuser is sudo of course This however was temporary and I had to create a loop in bash to run it every 30 seconds or so. #!/bin/bash while : do echo level full-speed | superuser tee /proc/acpi/ibm/fan #echo "Press [CTRL+C] to stop.." sleep 30 done –  maphilli14 Aug 24 '12 at 13:48
add comment

I have the same problem: thinkpad t500 with 12.05 LTS (64bit) is overheating. Temperatures are around 70+ C (idle) and can get easily over 80/90C.

When manually adjusting the fan speed in "/proc/acpi/ibm/fan", I can reduce the temperature a quite a bit but they are still high 60+. Somehow the fanspeed is not going automatically to the max (level 7 or "engaged") although temperatures are over 90C.

But I think the main problem is the automatic control of the cpu frequency. The use of powertop revealed that the cpus are running in "turbo mode" nearly all the time. Right now, just writing this repley in firefox, the turbo mode is 95%.

A easy solution to this problem is to install indicator-cpufreq and set the cpufreq manually or use powersave governor.

I feel no slowdown of the laptop but temperature are now around 40/45C when idle.

share|improve this answer
add comment

What about Kernel 3.4? Any news about that? It's really fixing the problem? Since my Lenovo T500 REALLY got overheated (was like a dream, but I saw a sparkle going from my laptop) I don't want to try and burn my laptop. So I would be really happy if anyone can tell me what is going on with 12.04 and overheating problem. Thanks!

p.s. As I said... Kernel 3.4 should be fixing this problem. Indicator-cpufreq doesn't really help. After little bit just jumps back to "ondemand" mode and get overheated. My laptop got a DEEP cleaning. So it's not "dust problem". :(

share|improve this answer
add comment

Any news? Anything new about overheating problem? I still have same problems about overheating with my lenovo T500. I did install AMD Catalyst 12.6 drivers, Jupiter and also modified grub and my cpu temp still gets high (highest 90+°C). I really need to find a solution... The fact is that in Windows 7 x64 my the average temp is 65°C. Running full screen flash (firefox/youtube) on ubuntu 12.04 is like having a barbeque on my laptop :(... In W7 is just little above 60°C. Where it comes that difference? p.s. Is not just using flash. Is any other app too. The average temp on ubuntu 12.04 is 15°C higher then W7. I had before 10.04 and never had any problem like that... The temp was even lower then W7. Would love to have 10.04 but there is a problem with app upgrades :( (or I just don't know how to upgrade app with the old kernel/ubuntu)

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.