Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I accidentally installed Canadian English instead of US English when I did my install. How can I set this back?

When I go to System Settings > Language Support English and English (Canada) are available, but English (United States), along with all other English variants, are greyed out.

"Install/Remove Languages" below does not have the granularity lower than English, so I can't select a country. How can I install US English?

share|improve this question
    
I see this is still an active question, so just to add a note: this was the result of ubuntu having Detroit listed as in Canada in 12.04, which was reported as a bug and subsequently corrected. –  Mittenchops Mar 15 at 21:16
add comment

2 Answers

up vote 7 down vote accepted

OK, I ended up doing this a different way.

First I googled around for the file where this setting is stored:

sudo nano /etc/default/locale

Then there were a bunch of '_CA' below that I changed to '_US' like so and everything worked.

LANG="en_US.UTF-8"
LANGUAGE="en_US:en"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"

And then USA #1.

share|improve this answer
add comment

Under Settings>Language Support just drag the greyed out English (United States) to the top, with plain English under that. This will activate the US locale. You may need to check the Regional settings tab as well.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.